Zwracanie wywołań RESTAPI trwa za długo, powodując błędy przekroczenia limitu czasu VSS w AppSync

概要: Zwracanie wywołań RESTAPI trwa za długo, powodując błędy przekroczenia limitu czasu VSS w AppSync

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Klient używa AppSync, który korzysta z RESTAPI w celu wykonania migawek na hostach Windows 2016. Używane jest rozwiązanie Microsoft VSS, które wymaga odpowiedzi w ciągu 10 sekund, a zapewnienie odpowiedzi przez RESTAPI trwa o wiele dłużej, nawet jeśli sesja snapvx zakończy się w mniej niż 1 sekundę.

W dziennikach AppSync widzimy zapytanie o migawkę, a zaraz potem widzimy rozpoczęcie tworzenia snapvx w dziennikach SYMAPI. Migawka jest wykonywana w mniej niż sekundę. Jednak zwrot z RESTAPI do AppSync nie występuje przez kolejne 30 sekund po ukończeniu tej operacji. W dziennikach SMAS i RESTAPI wyświetlą się poniższe informacje (wymagane jest rejestrowanie informacji w Unisphere):

INFO [em.bp.RESTAPIUSAGE] (default task-611) /private/91/replication/symmetrix/{symmetrixId}/snapshot/{snapshotName} AppSync/4.1.0.1_2492_R2/<adres_IP>    POST    36829 ms    201    null    null    null

原因

W tym przypadku ten problem pojawił się, gdy klient wykonywał migawki poszczególnych urządzeń, a nie na poziomie grupy pamięci masowej. Klient wykonywał migawki ponad 50 urządzeń, co przyczyniło się do wydłużenia czasu potrzebnego na zwrócenie zapytania RESTAPI z powrotem do AppSync. 

W celu obejścia tego problemu zespoły inżynierów opracowały zmianę architektury w celu dostosowania wywołań RESTAPI, aby odpowiadały w ciągu limitu czasu VSS wynoszącego 10 sekund

解決方法

Rozwiązanie: Dostępna jest poprawka do obejścia tego problemu. Istnieją poprawki zarówno dla Unisphere, jak i AppSync, które są wymagane do rozwiązania problemu. Prosimy skontaktować się z działem pomocy technicznej, odwołać się do tego artykułu z bazy wiedzyi poprosić o następujące poprawki:

- Unisphere for PowerMax 9.2.0.9
- Poprawka AppSync 4.1.0.1_2492_R3

Obie poprawki są wymagane do obejścia tego problemu.

対象製品

Unisphere for PowerMax
文書のプロパティ
文書番号: 000182815
文書の種類: Solution
最終更新: 06 11月 2025
バージョン:  6
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。