DPA:jobmonitorが「omnicellinfo」コマンドによりタイムアウトしてData Protectorに失敗する

概要: Data ProtectorサーバーのJobmonitorデータ リクエストが失敗し、「omnicellinfo」コマンドが原因でタイムアウトします。 その他のすべてのリクエストは正常に実行されています。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Data Protectorサーバーのjobmonitorがタイムアウトで失敗し、DPAがバックアップ データを収集していません。

「dpaagent log」に次のエラーが含まれています。

ERR      9425.9447     20210129:095944         agent.mod.dp - dpRunCmd(): timeout running omnicellinfo against server 'DP_server_hostname'

そのData Protectorサーバーに対するjobmonitorリクエストの履歴には、通常、次のように表示されます。
JobMonitorリクエスト履歴

 

原因

DPAのData Protectorモジュールの現在の設計では、データ収集中に「omnicellinfo」コマンドを複数回実行します。

リクエストのポーリング期間中にバックアップを実行したクライアントごとに「omnicellinfo」を1回実行しようとします
コマンドの実行に30秒から60秒以上かかる場合、たとえば100個のクライアントがそのポーリング期間内にバックアップを実行した場合、長い時間がかかります。

 

解決方法

Data Protectorサーバーで、次のコマンドを実行し、所要時間を確認します。

omnicellinfo -server <server hostname> -cell brief

コマンドに 1 分以上かかる場合 (最適なパフォーマンスを得るには 30 秒未満で実行するのが理想的です)、Micro Focus を使用して "omnicellinfo" の実行にかかる時間を短縮する必要があります。

詳細については、デル・テクニカル・サポートにお問い合わせください。

 

対象製品

Data Protection Suite, Data Protection Advisor
文書のプロパティ
文書番号: 000182957
文書の種類: Solution
最終更新: 20 1月 2025
バージョン:  4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。