SRM 4.5:4.5または4.5.0.1へのアップグレード後にWeb Service Gateway(WSG)サービスが実行されない:「Insufficient configured threads」例外
概要: Web Service Gateway(WSG)サービスは、16を超えるCPUコアを搭載したVMまたはホスト上のSRM 4.5および4.5.0.1では起動できません。これはまた、SRM 4.5および4.5.0.1へのアップグレードにも影響します。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
このKB記事で説明されている問題に関連する症状として、次の2つの可能性があります。
- 以下のSRMアップグレードがメンテナンス モードに入った直後に停止して完了しないことがある
(i)4.5から4.5.0.1へのアップグレード
(ii)以前のバージョンから4.5へのアップグレード - SRM 4.5または4.5.0.1で、WSGサービスがVMまたはホストで開始されず、次のエラーがログに記録される:
SEVERE -- [2021-02-08 14:38:00 AEDT] -- HttpServer$Service::publish(): an unexpected error occurred publishing com.watch4net.apg.webservice.proxy.ManagementServiceProxyHandler
java.lang.IllegalStateException: handler can't be initialized
(...)
Caused by: javax.servlet.ServletException: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]
(...)
Caused by: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]
この問題は、Linux/vAppホストとWindowsホストの両方に影響します。
原因
WSGは、Jetty、Java Webサーバー、およびJava Servletコンテナを使用しています。Jettyは、必要なプロセスに対して十分なスレッドを割り当てることができません。ある時点で表示されるスレッドの数は、ハードウェアの相違点(CPUコアの数、ネットワーク インターフェイスの数、カーネルの相違、Javaの相違、負荷の相違、アクティブ ユーザー数、アクティブな接続数、1秒あたりのトランザクション数など)によって大きく異なる場合があります。通常、仮想プロセッサー数が16を超えるVMとホストには、この問題が発生することが知られています。
解決方法
SRMサーバーでは、CPUコア数が16を超えると、WSGサービスを起動するためのスレッドが不足しているというエラーがWSGログに表示されます。Jettyを最新の9.4.34以降にアップグレードするには、十分なスレッドを作成するために必要なデフォルトの最大スレッド数(#10)を再構成する必要があります。
SRM VMまたはホストで16を超えるCPUコアを使用している場合は、Dell EMCオンライン サポート サイト(https://dell.com/support)にアクセスしてサービス リクエスト(SR)を開き、そのSRにこのナレッジベース記事番号を記載してください。
SRM VMまたはホストで16を超えるCPUコアを使用している場合は、Dell EMCオンライン サポート サイト(https://dell.com/support)にアクセスしてサービス リクエスト(SR)を開き、そのSRにこのナレッジベース記事番号を記載してください。
製品
SRM, SRM文書のプロパティ
文書番号: 000184212
文書の種類: Solution
最終更新: 08 5月 2026
バージョン: 7
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。