Data Protection Advisor(DPA):PPDMリクエストが失敗し、関数キャッチProcessingExceptionが発生する

概要: PPDMのデータ コレクション リクエストが失敗し、メッセージ関数がProcessingExceptionをキャッチしました。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

PPDMのジョブ モニター データ収集リクエストが次のステータスで失敗します。
Function jobmonitor caught ProcessingException

The Debug low dpaagent.logは、例外の原因となったAPIリクエストをキャプチャーします:
DBG1 。 20210305:014537 org.apache.logging.log4j.spi.AbstractLogger-get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR です。 20210305:014637 org.apache.logging.log4j.spi.AbstractLogger-execute(): 関数jobmonitorがProcessingExceptionをキャッチしました


ログには、APIリクエストとProcessingExceptionメッセージの間にちょうど60秒あることが示されています。

原因

PPDMジョブ監視リクエスト内に、[Request Timeout (Seconds)]というオプションがあります
このタイムアウトのデフォルト値は60秒です
場合によっては、PPDMサーバーが60秒のタイムアウト内にリクエストに応答せず、DPAでProcessingExceptionメッセージが表示されることがあります。

解決方法

REST APIクライアントを使用して、PPDMサーバーがリクエストに応答するのにかかる時間を確認します。
リクエストが成功するまで、PPDMリクエストのRequest Timeout (Seconds)オプションを増やします

詳細については、Dellテクニカル サポートにお問い合わせください。

製品

Data Protection Advisor
文書のプロパティ
文書番号: 000184327
文書の種類: Solution
最終更新: 08 5月 2026
バージョン:  4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。