Windows Server:リモート デスクトップ接続確立時のリモート デスクトップ エラー

概要: ユーザーがサーバーへのリモート デスクトップ接続を確立しようとすると、次のエラー メッセージが表示されることがあります。"ライセンスを提供できるリモート デスクトップ ライセンス サーバーがないため、リモート セッションは切断されました。"

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

ユーザーが

サーバーへのリモート デスクトップ接続を確立しようとすると、「ライセンスを提供できるリモート デスクトップ ライセンス サーバーがないため、リモート セッションは切断されました」というエラー メッセージが表示されることがあります。

 

  • リモート デスクトップ ライセンス マネージャーは、リモート デスクトップ (RD) クライアント アクセス ライセンス (CAL) がライセンス サーバーにインストールされていることを示します。
  • リモート デスクトップ ライセンス診断ツールには、正しいライセンス サーバーが使用されていることが表示されます。
  • 最も注目すべきは、次の図に示すように、リモート デスクトップ ライセンス マネージャーにリストされているRD CALにオペレーティング システムのバージョンが表示されないことです。
    オペレーティング システム バージョンのないCALを示すリモート デスクトップ ライセンス マネージャーのスクリーンショット図1: オペレーティング システム バージョンが記載されていないインストール済みCALを表示するリモート デスクトップ ライセンス マネージャーのスクリーンショット

 

注:この記事では、特定の状況について説明しますが、他の状況でも同じエラーが発生する可能性があります。「現象」セクションの情報を確認して、この記事が該当することを確認します。

原因

これは、インストールされている RD CAL が、RD ライセンス サーバーで実行されているオペレーティング システムよりも新しいバージョンのオペレーティング システム用である場合に発生します。たとえば、ライセンス サーバーがWindows Server 2019を実行していて、Windows Server 2022 RD CALがインストールされている場合、このエラーが発生します。

解決方法

この問題を解決するには、次の3つの方法があります。
  • インストールされているRD CALのバージョンと一致するように、ライセンス サーバーのオペレーティング システムをアップグレードします。これには、有効で未使用のWindows Serverライセンスとプロダクト キーが必要です。
  • 新しいオペレーティング システムを実行している既存のサーバーに RD ライセンスの役割サービスをインストールします。RD CAL を移行し、ライセンス サーバーとして使用するようにリモート デスクトップ サービスの展開を構成します。
  • Microsoft クリアリング ハウスに連絡し、RD CAL をライセンス サーバーで実行されているバージョンにダウングレードしてもらいます。Dellサポートは、Microsoft Clearinghouseへの連絡を支援できます。

対象製品

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

製品

C Series, HS Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
文書のプロパティ
文書番号: 000218177
文書の種類: Solution
最終更新: 09 12月 2024
バージョン:  6
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