PowerScale:SMBプロセスのaudit_fltドライバーがクローズされた状態であるため、ノードが使用不可になっています
概要: OneFS 9.7コードで、SMB(Server Message Block)プロセスで監査ドライバーが正しくロードされない問題が特定されました。これにより、データ欠損につながる可能性があります。
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現象
この問題は、9.7.1.0から9.7.1.7リリースのコード レベルを実行しているクラスターに影響する可能性があります。
主な症状は次のとおりです。
- SMBユーザーは、一部またはすべてのノードにアクセスできません。
- 一部またはすべてのノードのSMBサービスで、多数の接続が
CLOSED状態。接続中にCLOSED状態はさまざまな理由で発生する可能性がありますが、この特定の問題に関連する症状でもあります。これを確認するには、次のコマンドを使用します。
isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
すべての情報が表示されることを '0' を出力します。以下は、この問題が発生しているクラスターの例です。
MyCluster-1# isi_for_array -X 'netstat -an | grep "\.445 " | grep CLOSED | wc -l' | sort -V
MyCluster-1: 208
MyCluster-2: 425
MyCluster-3: 2228
MyCluster-4: 146
MyCluster-5: 5284
MyCluster-6: 964
- 監査がクラスターで有効になっています。次のコマンドで確認します。
isi audit settings global view | grep "Protocol Auditing"
MyCluster-1# isi audit settings global view | grep "Protocol Auditing"
Protocol Auditing Enabled: Yes
- クラスターは、影響を受けるコード(9.7.1.0 - 9.7.1.7)を実行しています。
クラスターでこの問題が発生しているかどうかを最終的に判断するには、 Dellサポートにサービス リクエストを発行します。これらは、Like Input/Output (LWIO)サービスからのSMBコアダンプを調べるのに役立ちます。
原因
この問題は、SMBプロセスが audit_flt ドライバーが起動します。この問題は通常、コードのアップグレード中、またはクラスター間のフェールオーバーとフェールバック中など、SMBサービスが再起動されたときにトリガーされます。ただし、何らかの理由でSMBが再起動された場合に発生する可能性があります。
解決方法
この問題を軽減するには、SMBサービスを再起動します。通常の状況では、分離されたSMB再起動で十分です。
MyCluster-1# killall -6 lwio
これは、複数のノードで実行できます。 isi_for_array.
以下は、ノード1-4でSMBサービスを再起動する例です。
MyCluster-1# isi_for_array -n1-4 'killall -6 lwio'
これで問題が軽減されない場合は、SMBとすべての依存関係の再起動が必要になる場合があります。
MyCluster-1# /usr/likewise/bin/lwsm restart lwio
この場合も、複数のノードで同時に isi_for_array.
以下は、ノード1-4でSMBスタックを再起動する例です。
MyCluster-1# isi_for_array -n1-4 '/usr/likewise/bin/lwsm restart lwio'
この問題は、OneFS 9.7.1.8コード以降で対処されています。
対象製品
Isilon, PowerScale OneFS文書のプロパティ
文書番号: 000286634
文書の種類: Solution
最終更新: 27 1月 2026
バージョン: 5
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