NetWorker:19.13.0.2へのアップグレード後にNMM SQLバックアップが失敗します - アクティブなSQL Serverが見つかりません。

概要: 19.13.0.2へのアップグレード後にNMM SQLバックアップが失敗します - アクティブなSQL Serverが見つかりません。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

お客様はNMM 19.10を実行しており、バックアップは正常に実行されていました。

19.13.0.2にアップグレードした後、バックアップが次のエラーで失敗しました。

98188: nsrsqlsv: No Active SQL Server found.

98921: nsrsqlsv: Failed to get preferred node for backup of Availability group (xxxxxxxxxxx) with error: [bsGetPreferredNodeOnCurrentNode]: Availability Group (xxxxxxxxxxx) not found on node..

38008: nsrsqlsv: SSL Provider: The certificate chain was issued by an authority that is not trusted.

原因

(NMMバージョン19.10以降、DNSとrDNSに関連するコードに変更が加えられました)

解決方法

この問題を解決するために実行した手順は次のとおりです。

  1. クラスター インスタンス、各ノード、バックアップ サーバー、Data Domainのバックアップ サーバーのホスト ファイルにホスト ファイル エントリー(IP、FQDN、短い名前)を追加しました。
  2. クラスター インスタンス、各ノード、バックアップ サーバー、Data Domainの両方のノードのホスト ファイルにホスト ファイル エントリー(IP、FQDN、短い名前)を追加しました。
  3. インストールされているOLEデータベースドライバがバージョン18.xまたは19.xの場合は、フラグ2を1に設定して有効にします。
  4. アップグレードを実行します。
  5. バックアップ サーバーとSQLノードからピア情報をクリアします。
  6. バックアップを実行します。その後、バックアップは成功しました。

対象製品

NetWorker Module

製品

NetWorker Family, NetWorker, NetWorker Module for Microsoft
文書のプロパティ
文書番号: 000429113
文書の種類: Solution
最終更新: 27 4月 2026
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。