CloudLink: Aws-consoletoegang tot CloudLink OS uitschakelen
Samenvatting: AWS heeft vooraf geïnstalleerde SSM-agent op alle ondersteunde besturingssystemen. Deze SSM-agent geeft ook rechtstreeks toegang tot de CloudLink OS-console.
Dit artikel is van toepassing op
Dit artikel is niet van toepassing op
Dit artikel is niet gebonden aan een specifiek product.
Niet alle productversies worden in dit artikel vermeld.
Symptomen
Dell raadt aan om de SSM-agent uit CloudLink-instanties te verwijderen, omdat dit leidt tot beveiligingslekken.
Oorzaak
In AWS is de SSM-agent vooraf geïnstalleerd op alle ondersteunde besturingssystemen om rechtstreeks toegang tot de console van het besturingssysteem toe te staan.
Van toepassing op producten en versies: Alle versies van CloudLink tot 7.1.3 wanneer geïmplementeerd in AWS.
Van toepassing op producten en versies: Alle versies van CloudLink tot 7.1.3 wanneer geïmplementeerd in AWS.
Oplossing
Om aanmelding via Session Manager naar CloudLink OS uit te schakelen, moet de Administrator de SSM-agent uit de CloudLink-instantie verwijderen.
Er zijn twee tijdelijke oplossingen:
herstelworkflow 1: Wanneer de gebruiker toegang heeft tot de CloudLink-console via Session Manager.
Herstelworkflow 2: Wanneer de gebruiker geen toegang heeft tot de CloudLink-console via Session Manager.
Herstelworkflow 1:
1. Exemplaar van CloudLink.
2. Klik op het tabblad Session Manager -> klik op Connect knop
3. Zodra u in de CloudLink-console bent met Session Manager, voert u sudo su
4 in. Om de status van de SSM-agent te controleren die wordt uitgevoerd op de CloudLink-console, voert u de onderstaande opdracht
"systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"
5 uit. Voer de onderstaande opdracht
"snap list amazon-ssm-agent"
6 uit om de actieve SSM-agent op de CloudLink-console weer te geven. Om de SSM-agent uit de CloudLink-console te verwijderen, voert u de onderstaande opdracht
"snap remove amazon-ssm-agent"
Validate SSM agent is removed from CloudLink instance uit.
7. Wanneer de SSM-agent cloudlink-instantie wordt verwijderd, wordt de knop 'verbinden' uitgeschakeld
8. Wanneer de gebruiker probeert om naar het CloudLink IP-adres te SSH te gaan, gaat de gebruiker naar CloudLink-aanmeldingsprompt
9. Controleer op de status van de SSM-agent. Controleer of de agent is 'Gestopt'10
. Controleer de lijst met SSM-agents. Status retourneren "No matching snaps installed".
Herstelworkflow 2:
Session Manager is niet ingeschakeld wanneer er geen IAM-rol is geselecteerd. Zonder de aanwezigheid van Session Manager kan de gebruiker dus geen toegang krijgen tot de CloudLink-console.
Als u het IAM-profiel wilt controleren, meldt u zich aan bij AWS -> Launch EC2 instance -> Advanced details -> IAM Instance profile
Aanbevolen om geen profiel te selecteren onder 'IAM Instance profile'. Dit leidt ertoe dat Session Manager geen verbinding kan maken met de CloudLink-console.
OPMERKING: Op dit punt wanneer Session Manager geen verbinding kan maken met de CloudLink-console, moet de gebruiker contact opnemen met Technische Support om te helpen bij het verwijderen van de SSM-agent uit CloudLink-instanties.
Er zijn twee tijdelijke oplossingen:
herstelworkflow 1: Wanneer de gebruiker toegang heeft tot de CloudLink-console via Session Manager.
Herstelworkflow 2: Wanneer de gebruiker geen toegang heeft tot de CloudLink-console via Session Manager.
Herstelworkflow 1:
1. Exemplaar van CloudLink.
2. Klik op het tabblad Session Manager -> klik op Connect knop
3. Zodra u in de CloudLink-console bent met Session Manager, voert u sudo su
4 in. Om de status van de SSM-agent te controleren die wordt uitgevoerd op de CloudLink-console, voert u de onderstaande opdracht
"systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"
5 uit. Voer de onderstaande opdracht
"snap list amazon-ssm-agent"
6 uit om de actieve SSM-agent op de CloudLink-console weer te geven. Om de SSM-agent uit de CloudLink-console te verwijderen, voert u de onderstaande opdracht
"snap remove amazon-ssm-agent"
Validate SSM agent is removed from CloudLink instance uit.
7. Wanneer de SSM-agent cloudlink-instantie wordt verwijderd, wordt de knop 'verbinden' uitgeschakeld
8. Wanneer de gebruiker probeert om naar het CloudLink IP-adres te SSH te gaan, gaat de gebruiker naar CloudLink-aanmeldingsprompt
9. Controleer op de status van de SSM-agent. Controleer of de agent is 'Gestopt'10
. Controleer de lijst met SSM-agents. Status retourneren "No matching snaps installed".
Herstelworkflow 2:
Session Manager is niet ingeschakeld wanneer er geen IAM-rol is geselecteerd. Zonder de aanwezigheid van Session Manager kan de gebruiker dus geen toegang krijgen tot de CloudLink-console.
Als u het IAM-profiel wilt controleren, meldt u zich aan bij AWS -> Launch EC2 instance -> Advanced details -> IAM Instance profile
Aanbevolen om geen profiel te selecteren onder 'IAM Instance profile'. Dit leidt ertoe dat Session Manager geen verbinding kan maken met de CloudLink-console.
OPMERKING: Op dit punt wanneer Session Manager geen verbinding kan maken met de CloudLink-console, moet de gebruiker contact opnemen met Technische Support om te helpen bij het verwijderen van de SSM-agent uit CloudLink-instanties.
Getroffen producten
CloudLink SecureVM, CloudLinkArtikeleigenschappen
Artikelnummer: 000200819
Artikeltype: Solution
Laatst aangepast: 09 nov. 2022
Versie: 5
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.