Data Domain: Alert — moduł we/wy nie powiódł się | EVT-ŚRODOWISKO-00029

Podsumowanie: System Data Domain (DD) generuje alert EVT-ENVIRONMENT-00029 z komunikatem "Moduł we/wy uległ awarii", gdy moduł we/wy PCIe (znany również jako karta SLIC lub PCI) ulegnie awarii lub zostanie usunięty. Dotyczy to różnych typów kart: SAS, NIC, NVRAM i Fibre Channel (FC). ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Ten artykuł bazy wiedzy dotyczy urządzeń PCIe; ten sam alert można również wygenerować dla modułu TPM (Trusted Platform Module).

W przypadku modułu TPM, który uległ awarii, zapoznaj się z artykułem  bazy wiedzyData Domain: Alert: ENVIRONMENT-00029: Moduł we/wy TPM uległ awarii

Awaria lub usunięcie karty we/wy (na przykład SAS, NIC, NVRAM, FC) powoduje utratę komunikacji z kartą, której dotyczy problem.

  • Zamiana urządzeń PCIe bez wyłączania systemu NIE jest obsługiwana. System DD MUSI być wyłączony, aby można było ponownie podłączyć lub zainstalować urządzenie PCIe.
  • Zamiana bez wyłączania systemu powoduje nieoczekiwane ponowne uruchomienie systemu.

Przykład alertu:

Alert Id:       147
Event Id:       EVT-ENVIRONMENT-00029
Event Message:  I/O module has failed
Object:         Enclosure=1:Slot=7
Additional Information: Cause=A hardware fault occurred

Przyczyna

Moduł we/wy PCIe (SLIC lub karta PCI) uległ fizycznej awarii z powodu awarii sprzętowej lub został usunięty z gniazda podczas pracy systemu. 
W niektórych przypadkach zdarzenie przejściowe, takie jak usterka oprogramowania wewnętrznego, może wywołać tymczasowe zresetowanie karty, które również generuje ten alert. 

Rozwiązanie

Krok 1 - Potwierdź status karty, której dotyczy problem

  1. Połącz się z systemem DD przez SSH (DDCLI).
  2. Uruchom polecenie system show hardware , aby wyświetlić spis sprzętu.
  3. Przejrzyj dane wyjściowe. Uszkodzona lub usunięta karta wyświetla się jako (empty) W gnieździe:  

Example:

sysadmin@DD# system show hardware
Slot   Vendor   Device                            Ports
----   ------   -------------------------------   --------------
M      QLogic   QL41000 4x 10GBase-T (NDC)        Ma, Mb, Mc, Md
1      QLogic   QL41164 4x 10GbE SFP+             1a, 1b, 1c, 1d
2      EMC      NVRAM 16GB Card
3      EMC      PMC Quad Port 12 Gbps SAS         3a, 3b, 3c, 3d
4      Intel    Intel QuickAssist Adapter 8970
5      EMC      Quad Port 16 Gbps Fibre Channel   5a, 5b, 5c, 5d
6      QLogic   QL41000 2x 25GbE                  6a, 6b
7      (empty)         (empty)
8      QLogic   QL41000 2x 25GbE                  8a, 8b
----   ------   -------------------------------   --------------

W tym przykładzie gniazdo 7 jest pokazane jako (empty), ponieważ karta w tym gnieździe uległa awarii.

  1. Jeśli nie wszystkie gniazda są zapełnione, porównaj bieżące dane wyjściowe z poprzednim raportem automatycznej pomocy technicznej, aby zidentyfikować brakującą kartę.

Krok 2 — sprawdź, czy alert jest przejściowy
Ten alert może być przejściowy. W niektórych przypadkach system skutecznie odzyskuje kartę samodzielnie, na przykład po zresetowaniu karty przez zdarzenie oprogramowania wewnętrznego.
W większości przejściowych przykładów opublikowany alert usuwa się sam i nie są wymagane żadne dodatkowe działania. 

  1. Uruchom ponownie system show hardware po kilku minutach.
  2. Jeśli karta ponownie pojawi się na wyjściu i wznowi normalną pracę, alert był przejściowy. Usuń alert i monitoruj system pod kątem jego powtarzalności.
  3. Jeśli karta pozostaje w stanie uszkodzonym lub (empty) przejdź do kroku 3.

Krok 3 - Sprawdzanie i usuwanie aktywnych aktów oskarżenia
Awaria sprzętowa może spowodować, że system DD utworzy akt oskarżenia przeciwko elementowi, którego dotyczy problem. Aktywne akty oskarżenia mogą uniemożliwić wykonanie niektórych operacji lub wywołać dodatkowe alerty.
Sprawdź i wyczyść wszelkie akty oskarżenia związane z uszkodzonym modułem we/wy.

  1. Uruchom polecenie # system indict list , aby wyświetlić listę wszystkich aktywnych aktów oskarżenia w systemie:
  2. Przejrzyj dane wyjściowe i zidentyfikuj wszelkie oskarżenia związane z uszkodzonym modułem we/wy (zgodne z informacjami o obudowie i gnieździe z alertu).
  3. Usuń każdy odpowiedni akt oskarżenia, uruchamiając następujące polecenie, zastępując <indict-id#> z indictment ID Z danych wyjściowych: # system indict remove <indict-id#>
  4. Uruchom ponownie system indict list w celu potwierdzenia, że akt oskarżenia został skutecznie wycofany. Przejdź do kroku 4 , jeśli karta pozostaje w stanie awarii lub (empty) Państwa.
Uwaga: Akty oskarżenia należy usuwać dopiero po potwierdzeniu pierwotnej przyczyny lub zakończeniu powiązanej akcji windykacyjnej. Usunięcie aktu oskarżenia nie rozwiązuje podstawowego problemu ze sprzętem.

Krok 4 - Spróbuj odzyskać system, ponownie uruchamiając system

  1. Uruchom ponownie system DD, uruchamiając # system reboot przez SSH.
  2. Po ponownym uruchomieniu systemu uruchom polecenie system show hardware , aby sprawdzić, czy karta została odzyskana.
  3. Jeśli karta została wykryta i działa normalnie, skasuj alert (# alert clear <alert-id>), oczyścić akty oskarżenia (zgodnie z krokiem 3) i kontynuować monitorowanie pod kątem ponownego wystąpienia.
  4. Jeśli karta nadal jest wyświetlana jako (empty) lub zakończył się niepowodzeniem, przejdź do kroku 5.

Krok 5 – Ponownie osadź lub ponownie zainstaluj kartę
Jeśli karta została przypadkowo wyjęta, zainstalowana w niewłaściwym gnieździe lub musi zostać zamontowana ponownie:

  1. Wyłącz system DD, uruchamiając # system poweroff przez SSH.
  2. Zainstaluj (lub ponownie osadź kartę) kartę we/wy w odpowiednim gnieździe.
  3. Ponownie włącz system.
  4. Uruchom system show hardware , aby potwierdzić wykrycie karty.
  5. Uruchom system indict list w celu sprawdzenia, czy nie pozostały żadne akty oskarżenia. Usuń wszelkie nieaktualne akty oskarżenia za pomocą system indict remove <indict-id#>
  6. Jeśli karta nadal nie wygląda lub nie działa, przejdź do kroku 6.

Krok 6 - Skontaktuj się z pomocą
techniczną
Jeśli po wykonaniu powyższych czynności karta nadal uległa awarii, prawdopodobnie jest uszkodzona. 
Skontaktuj się z usługodawcą pomocy technicznej firmy Dell, aby zbadać usterkę i zorganizować naprawę lub wymianę.

Aby przyspieszyć zgłoszenie serwisowe, potwierdź, że kroki od 1 do 5 zostały wykonane, a następnie wygeneruj nowy pakiet pomocy technicznej i dołącz go do zgłoszenia serwisowego.

Produkty, których dotyczy problem

Data Domain, Data Domain Deduplication Storage Systems, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
Właściwości artykułu
Numer artykułu: 000203868
Typ artykułu: Solution
Ostatnia modyfikacja: 14 lip 2026
Wersja:  8
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.