SRM 4.5: O serviço Web Service Gateway (WSG) para de ser executado após o upgrade para a versão 4.5 ou 4.5.0.1: Exceção "Insufficient configured threads"

Resumo: O serviço Web Service Gateway (WSG) não é iniciado nas VMs ou nos hosts do SRM 4.5 e 4.5.0.1 com mais de 16 núcleos de CPU. Isso também afeta os upgrades do SRM para as versões 4.5 e 4.5.0.1. ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Dois possíveis sintomas estão associados ao problema descrito neste artigo da KB:
  • Os upgrades do SRM abaixo podem ficar paralisados logo após entrar no Modo de manutenção e não ser concluídos
    (i) Upgrade da versão 4.5 para a 4.5.0.1
    (ii) Upgrade das versões anteriores para a 4.5
  • No SRM 4.5 ou 4.5.0.1, o serviço WSG não é iniciado em VMs ou hosts e registra os seguintes erros:      

SEVERE -- [2021-02-08 14:38:00 AEDT] -- HttpServer$Service::publish(): an unexpected error occurred publishing com.watch4net.apg.webservice.proxy.ManagementServiceProxyHandler
java.lang.IllegalStateException: handler can't be initialized
       (...)
Caused by: javax.servlet.ServletException: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]
       (...)
Caused by: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]


O problema afeta hosts do Linux/vApp e do Windows.

Causa

O WSG está usando o Jetty, um servidor Web Java e um contêiner servlet Java. O Jetty não consegue alocar threads suficientes para os processos necessários. O número de threads que podem ser vistos em determinado momento variam bastante de acordo com as diferenças de hardware (número de núcleos de CPU, número de interfaces de rede, diferenças de kernel, diferenças de Java, diferenças de carga, contagens de usuários ativos, contagens de conexões ativas, transações por segundo etc.). Geralmente, as VMs e os hosts com mais de 16 processadores virtuais apresentam esse problema.

Resolução

Em qualquer servidor SRM, se a contagem de núcleos de CPU for superior a 16, os logs do WSG mostrarão erros sobre threads insuficientes para iniciar o serviço WSG. O upgrade mais recente do Jetty para a versão 9.4.34 ou superior requer uma reconfiguração do número máximo padrão da contagem de threads (10) para criar threads suficientes.

Se você tiver mais de 16 núcleos de CPU na VM ou no host do SRM, acesse o site de suporte on-line da Dell EMC (https://dell.com/support) para abrir um Chamado (SR) e mencione o número deste artigo da base de conhecimento.

Produtos

SRM, SRM
Propriedades do artigo
Número do artigo: 000184212
Tipo de artigo: Solution
Último modificado: 08 mai. 2026
Versão:  7
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.