Zálohování virtuálního počítače selhává s chybou "Unable to delete pre-existing snapshots: Další úloha již probíhá."
Resumo: Zálohování virtuálních počítačů selhává a zobrazí se následující chyba: 2021-04-14T17:46:35Z CHYBA: [@(#) Build number: 51] Nepodařilo se dokončit odebrání snapshotu "snapshot-347817": Another task is already in progress. 2021-04-14T17:46:35Z CHYBA: [@(#) Build number: 51] Nelze odstranit stávající snapshoty: Another task is already in progress. ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
Zálohování virtuálního počítače selhává pro jeden virtuální počítač.
Vytvoření ručního snapshotu virtuálního počítače také selže s následující chybou:
Vytvoření ručního snapshotu virtuálního počítače také selže s následující chybou:

Causa
Zastaralá úloha se zobrazuje na hostiteli ESXi pro daný virtuální počítač.
Resolução
1) Přihlaste se do vcenter a zkontrolujte, zda jsou k virtuálnímu počítači připojeny nějaké staré snapshoty (pokud jsou k dispozici – odstraňte/zkonsolidujte je).
2) Zkontrolujte, zda jsou v systému vproxy přítomny nějaké snapshoty (pokud jsou přítomny, odstraňte je nebo zkonsolidujte).
Pokud se na virtuálním počítači nebo nástroji vproxy nezjistí žádné starší snapshoty, proveďte níže uvedené kroky a zkontrolujte aktivní úlohy virtuálního počítače na hostiteli ESXI:
1) Přihlaste se k hostiteli ESX v konzoli nebo pomocí protokolu SSH
2). Chcete-li vygenerovat seznam úloh spojených s konkrétními virtuálními počítači, musíte nejprve získat virtuální počítač. Spusťte příkaz:
vim-cmd vmsvc/getallvms
. Výstup je podobný
: Vmid Name File Guest OS Version Annotation
112 VM-1 [Datastore] VM-3/VM-3.vmx winLongarnAdest vmx-04
128 VM-2 [Datastore] VM-3/VM-3.vmx winXPPro Engt vmx-04
144 VM-3 [Datové úložiště] VM-3/VM-3.vmx winNetStandardArnt vmx-04
3) Poznamenejte si hodnoty ve sloupci Vmid, jak je uvedeno v pozdějších krocích.
4) Pokud máte virtuální počítač, můžete získat seznam úloh spojených s konkrétním virtuálním počítačem. Spusťte příkaz:
vim-cmd vmsvc/get.tasklist VMID
, kde VMIDis zobrazí číslo uvedené v kroku 3.
Výstup je podobný
: (ManagedObject Task) [
'vim.Task:haTask-112-vim.VirtualMachine.createSnapshot-3887'
]
5). Poznamenejte si identifikátor úlohy. Ve výše uvedeném příkladu je identifikátor úlohy:
haTask-112-vim.VirtualMachine.createSnapshot-3887
6). Chcete-li získat informace o stavu konkrétní úlohy, spusťte příkaz:
vim-cmd vimsvc/task_info task_identifier
Where task_identifier is the string recorded in step 5.
Výstup je podobný:
(vim.TaskInfo) {
dynamicType = ,
key = "haTask-112-vim.VirtualMachine.createSnapshot-3887",
task = 'vim.Task:haTask-112-vim.VirtualMachine.createSnapshot-3887',
description = (vmodl. Localizable Iis) null,name
= "vim.VirtualMachine.createSnapshot",
descriptionId = "VirtualMachine.createSnapshot",
entity = 'vim.VirtualMachine:112',
entityName = "deploy-test",
state = "running",
cancelled = false,
cancelable = false,error
= (vmodl. MethodFault) null,result
= ,
progress = 15,reason
= (vim.TaskReasonUser) {
dynamicType = ,
userName = "root",
},
queueTime = "2012-11-28T01:29:35.233835Z",
startTime = "2012-11-28T01:29:35.234891Z",
completeTime = ,
eventChainId = 2936866,changeTag
= ,
parentTaskKey = ,
rootTaskKey = ,
Pokud jsou přítomny nějaké aktivní úlohy, musí to znovu potvrdit tým VMware a další kroky, které musí podniknout odpovídajícím způsobem podpora společnosti VMware.
2) Zkontrolujte, zda jsou v systému vproxy přítomny nějaké snapshoty (pokud jsou přítomny, odstraňte je nebo zkonsolidujte).
Pokud se na virtuálním počítači nebo nástroji vproxy nezjistí žádné starší snapshoty, proveďte níže uvedené kroky a zkontrolujte aktivní úlohy virtuálního počítače na hostiteli ESXI:
1) Přihlaste se k hostiteli ESX v konzoli nebo pomocí protokolu SSH
2). Chcete-li vygenerovat seznam úloh spojených s konkrétními virtuálními počítači, musíte nejprve získat virtuální počítač. Spusťte příkaz:
vim-cmd vmsvc/getallvms
. Výstup je podobný
: Vmid Name File Guest OS Version Annotation
112 VM-1 [Datastore] VM-3/VM-3.vmx winLongarnAdest vmx-04
128 VM-2 [Datastore] VM-3/VM-3.vmx winXPPro Engt vmx-04
144 VM-3 [Datové úložiště] VM-3/VM-3.vmx winNetStandardArnt vmx-04
3) Poznamenejte si hodnoty ve sloupci Vmid, jak je uvedeno v pozdějších krocích.
4) Pokud máte virtuální počítač, můžete získat seznam úloh spojených s konkrétním virtuálním počítačem. Spusťte příkaz:
vim-cmd vmsvc/get.tasklist VMID
, kde VMIDis zobrazí číslo uvedené v kroku 3.
Výstup je podobný
: (ManagedObject Task) [
'vim.Task:haTask-112-vim.VirtualMachine.createSnapshot-3887'
]
5). Poznamenejte si identifikátor úlohy. Ve výše uvedeném příkladu je identifikátor úlohy:
haTask-112-vim.VirtualMachine.createSnapshot-3887
6). Chcete-li získat informace o stavu konkrétní úlohy, spusťte příkaz:
vim-cmd vimsvc/task_info task_identifier
Where task_identifier is the string recorded in step 5.
Výstup je podobný:
(vim.TaskInfo) {
dynamicType = ,
key = "haTask-112-vim.VirtualMachine.createSnapshot-3887",
task = 'vim.Task:haTask-112-vim.VirtualMachine.createSnapshot-3887',
description = (vmodl. Localizable Iis) null,name
= "vim.VirtualMachine.createSnapshot",
descriptionId = "VirtualMachine.createSnapshot",
entity = 'vim.VirtualMachine:112',
entityName = "deploy-test",
state = "running",
cancelled = false,
cancelable = false,error
= (vmodl. MethodFault) null,result
= ,
progress = 15,reason
= (vim.TaskReasonUser) {
dynamicType = ,
userName = "root",
},
queueTime = "2012-11-28T01:29:35.233835Z",
startTime = "2012-11-28T01:29:35.234891Z",
completeTime = ,
eventChainId = 2936866,changeTag
= ,
parentTaskKey = ,
rootTaskKey = ,
Pokud jsou přítomny nějaké aktivní úlohy, musí to znovu potvrdit tým VMware a další kroky, které musí podniknout odpovídajícím způsobem podpora společnosti VMware.
Propriedades do artigo
Número do artigo: 000185657
Tipo de artigo: Solution
Último modificado: 23 ago. 2022
Versão: 5
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.