Dell Unity: Unity NAS 서버에서 NFS(NFSv4만 해당) 및 활성 연결 NFS 클라이언트(NFSv3 및 NFSv4 모두)에 대해 활성 열린 파일 수를 확인하는 방법(사용자가 수정 가능)

Resumo: 이 KB는 라이브 Unity 시스템에서 NFS(NFSv4만 해당) 및 활성 연결 NFS 클라이언트(NFSv3 및 NFSv4 모두)에 대한 활성 오픈 파일 수를 확인하는 방법을 제공합니다.

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

클라이언트가 Unity NAS 서버에서 파일을 닫지 않고 너무 많은 파일을 열면 액세스 문제가 발생할 수 있습니다.

Dell EMC Unity: Linux 클라이언트가 Unity NFS 공유에서 파일/폴더를 열 수 없음(Dell EMC 수정 가능) | Dell US

NFS 및 활성 연결된 NFS 클라이언트에 대한 활성 열린 파일 개수를 식별하면 문제가 있는 클라이언트를 식별하는 데 도움이 될 수 있으므로 고객은 클라이언트에서 열린 파일을 닫고 클라이언트의 잘못된 동작을 조사하기 위해 적절한 조치를 취할 수 있습니다.

Causa

NFS 및 활성 연결된 NFS 클라이언트에 대한 활성 열린 파일 수를 식별하면 문제가 있는 클라이언트를 식별하여 고객이 적절한 조치를 취할 수 있습니다.

Resolução

NFSv3 및 NFSv4용 활성 연결 NFS 클라이언트를 얻으려면 OE 5.1 이상에서 실행되는 Unity 스토리지에서 svc_nfssupport -listClient 명령을 사용할 수 있습니다.  
 
01:27:16 root@VIRT2213Y2VF7N spa:/cores/service/user# svc_nfssupport NFS_test -listClient

NFS v3 Clients:
|--- 5.6.7.248

NFS v4 Clients:
|--- 5.6.7.242
|--- 5.6.7.249

 

5.1 미만의 OE를 실행하는 Unity 스토리지의 경우 연결된 NFS 클라이언트 목록을 가져오는 다른 방법은 NFS 클라이언트에서 "showmount -a " 명령을 실행하는 것입니다.  Unity SP에서도 명령을 실행할 수 있지만 루트 권한이 필요합니다. 
 
00:54:57 root@VIRT2213RTVFNA spa:/cores/service/user# showmount -a 5.6.7.22
All mount points on 5.6.7.22:
rhel8.peeps.lab:/NFS_export
solaris11.peeps.labL/NFS_export
rhel7.peeps.lab:/NFS_export

showmount 출력에서는 클라이언트가 NFSv3 또는 NFSv4를 통해 NFS 공유를 마운트하는지 여부를 알 수 없습니다.  

showmount 출력에 표시된 NFSv4와 NFSv3 클라이언트의 수를 확인해야 하는 경우 Dell Technologies 또는 공인 서비스 공급업체에 문의하여 추가 지원을 받고 이 문서를 참조하십시오.

NFSv3 열린 파일 수를 확인하는 방법은 없습니다.  NFSv4 열린 파일 수를 확인하는 데 사용되는 방법은 루트 액세스가 필요합니다.  NFSv4 열린 파일 수를 확인해야 하는 경우 Dell Technologies 또는 공인 서비스 공급업체에 문의하여 추가 지원을 받고 이 문서를 참조하십시오.

Produtos afetados

Dell EMC Unity
Propriedades do artigo
Número do artigo: 000204821
Tipo de artigo: Solution
Último modificado: 12 jun. 2023
Versão:  3
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.