NetWorker:PostgreSQLデータベースのバックアップが完了せず、「the parameter 'NSR_BACKUP_SCRIPT'is Not Set」というエラーが表示される
Resumo: NMDA PostreSQL DataBaseバックアップは、次の場合にOrchestrated Application Protectionを介して失敗します。NMCワークフロー構成とpostgresconfig.cfgでのNSR_BACKUP_LEVEL間のバックアップ セットのレベルの不一致。NMCワークフローから実行される場合はスケジュール バックアップのみが失敗し、手動バックアップはレベル NSR_CONFIG_FILE = /nsr/apps/config/postgresconfig.cfg に従ってクライアント コマンド ラインから機能します。 ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
同じバックアップ エラーが次に報告されます。
図1: NMCワークフロー バックアップがNSRバックアップ スクリプトが設定されていない場合に失敗する
図2:ポリシー ログのワークフロー エラー
図3:NMDA PostgreSQLログで同じエラーが報告される
- NMC(NetWorker Management Console)ワークフロー のバックアップが失敗し、「NSR_BACKUP_SCRIPT」をポイントするエラーが発生して savefs が設定されません。
図1: NMCワークフロー バックアップがNSRバックアップ スクリプトが設定されていない場合に失敗する
- ワークフローは、ポリシー ログに対して同じエラーを生成します。
図2:ポリシー ログのワークフロー エラー
- NMDA PostgreSQLログは、次の例のnsr/apps/logs/nsroappbackup_OAPP_year_month_day.hh_mm_ss.processID.log 「Process ID#257129」の下にあるクライアントから同じエラーを報告します。
図3:NMDA PostgreSQLログで同じエラーが報告される
Causa
バックアップ セットのレベルが正しくなされておらず、構成ファイルが一致しません。
図4:バックアップ構成のバックアップ レベルが増分に設定されている。
図5:クライアントの /nsr/apps/config/postgresconfig.cfg をフルに設定
- バックアップ構成のバックアップ レベルは、増分(Incr)に設定されます。
図4:バックアップ構成のバックアップ レベルが増分に設定されている。
- クライアントの /nsr/apps/config/postgresconfig.cfg を Full に設定します。
図5:クライアントの /nsr/apps/config/postgresconfig.cfg をフルに設定
Resolução
postgresconfig.cfgに一致するNMCのワークフロー構成で、バックアップのレベルを[Full]に修正します。
図6:ワークフロー構成でバックアップのレベルをフルに設定する
ワークフロー バックアップが実行され、正常に完了します。
図7:ワークフロー バックアップが正常に完了 -すべてのセッション
図8:ワークフロー バックアップが正常に完了しました
図6:ワークフロー構成でバックアップのレベルをフルに設定する
ワークフロー バックアップが実行され、正常に完了します。
図7:ワークフロー バックアップが正常に完了 -すべてのセッション
図8:ワークフロー バックアップが正常に完了しました
Produtos afetados
NetWorker, NetWorker Module for Databases and ApplicationsProdutos
NetWorker Family, NetWorker Series, NetWorker ModulePropriedades do artigo
Número do artigo: 000212516
Tipo de artigo: Solution
Último modificado: 01 mai. 2023
Versão: 2
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.