El registro de NVP vProxy no se completa con el mensaje "HTTP Error 500: Failed to find virtual machine with IP address" y VMware View no se carga

Resumo: El registro de vProxy falla con el mensaje "HTTP Error 500: No se pudo encontrar la máquina virtual con la dirección IP "vPROXY_IP_ADDRESs" cuando se configuró un nuevo ambiente para respaldos de vProxy. La vista de NMC de VMware y el nuevo asistente vProxy no muestran recursos de VMware. ...

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Sintomas

  • Un nuevo registro del dispositivo vProxy de NetWorker VMware Protection (NVP) no se completa con el código de error:
Unable to register NSR VMware proxy 'networker-vproxy.lab.exoduspoint.com': Received an HTTP code: 500, libCURL message: "", vProxy message: "Error received from vProxy ="500: Failed to find virtual machine with IP address "vPROXY_IP_ADDRESS".".  
  • Este error se observa en el archivo /nsr/logs/daemon.raw del servidor de NetWorker y en la ventana Alertas de NetWorker Management Console (NMC).
  • El asistente de vProxy nuevo no muestra ningún recurso de VMware.
  • La pestaña VMware View de NMC no muestra nada, incluso después de realizar una actualización de VMware View:
La pestaña VMware View de NMC no muestra nada
Figura 1: La pestaña VMware View de NMC no muestra nada.
 

Causa

El vCenter se agregó a NetWorker mediante una función personalizada. Al usuario de VMware se le asignan permisos globales en el nivel de vCenter, pero propagar está configurado en Falso.

Resolução

  1. Confirme qué cuenta de usuario se utiliza para agregar un vCenter a NetWorker. Esto se realiza mediante el comando nsradmin en el servidor de NetWorker:
nsradmin
print type: nsr hypervisor


Resultado del comando nsradmin para buscar el nombre de usuario
Figura 2 Resultado del comando nsradmin para buscar el nombre de usuario
 

NOTA: Un administrador o equipo de VMware o una cuenta de usuario de VMware con derechos administrativos deben completar las siguientes acciones.
  1. Inicie sesión en vCenter vSphere Web Client e inicie sesión con la cuenta administrator@vsphere.local (u otra cuenta de nivel de administrador). 
  2. Vaya a Administration > Access Control > Global Permissions y busque la cuenta de usuario en el paso 1.

Administración > Control de acceso > permisos globales > cuenta de usuario del paso 1
Figura 3: Administración > Control de acceso > permisos globales > cuenta de usuario del paso 1

  1. Asegúrese de marcar propagar e identificar la función:

Asegúrese de que propagar esté desactivado para la función
Figura 4: Asegúrese de que propagar esté desactivado para la función.

  1. Vaya a Administration > Access Control > Roles y asegúrese de que muestre la cuenta de usuario de VMware correcta con propagación configurada en Verdadero.

Administración > funciones de control de acceso > > cuenta de usuario con propagación configurada en Verdadero
Figura 5: Administración > Funciones de control de acceso> >cuenta de usuario con propagación establecida en Verdadero


NOTA: Este campo solo debe mostrar verdadero. Si tiene dos entradas que muestran "Falso" y "Verdadero", el problema persiste.
 
  1. Vuelva a NMC y asegúrese de que VMware View se cargue y muestre los recursos de VMware.

NMC muestra que VMware View se carga y tiene recursos de VMware
Figura 6: NMC muestra que VMware View carga y tiene recursos de VMware.

  1. Si VMware View se carga correctamente, regrese a Devices > VMware Proxies y registre el vProxy.

Produtos afetados

NetWorker

Produtos

NetWorker Series
Propriedades do artigo
Número do artigo: 000215265
Tipo de artigo: Solution
Último modificado: 27 mar. 2025
Versão:  4
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