Domena danych — problemy BoostFS ze skanerem zabezpieczeń i aplikacjami

Resumo: Program Boostfs na kliencie Linux i Windows działa nieoczekiwanie, gdy skaner zabezpieczeń lub aplikacje zabezpieczające skanują lub uzyskają dostęp do plików w punkcie montowania Boostfs. ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

Dysk zamontowany w BoostFS lub punkt montowania przestają odpowiadać.

Operacje tworzenia kopii zapasowych z aplikacji mogą zakończyć się niepowodzeniem z niepowodzeniem odczytu i zapisu na plikach w punkcie montowania. Przykład:
​​Apr 19 10:15:09.853 29214 2269886208 [E] [ddp log] [721E:7FC860125190] ddcl_ddcp_pwrite: Error in ddcl_ddcp_pwrite. [ERR=5002]
Apr 19 10:15:13.990 29214 2269886208 [E] [ddp log] [721E:7FC860125190] ddcl_ddcp_pwrite: Error in ddcl_ddcp_pwrite. [ERR=5002]
 
Program Boostfs wydaje się mieć częste rozłączenia i błędy ponawiania próby.
Feb 24 19:52:46.803 423080 2833229568 [I] bfs_node_lookup: failed to obtain a connection; file=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2
Feb 24 19:52:46.803 423080 2833229568 [E] bfs_node_retry_conn: lookup failed path=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2
Feb 24 19:52:46.803 423080 2833229568 [E] bfs_open: lookup failed file=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2
Feb 24 19:52:46.803 423080 2833229568 [P] BFSPROC_EXIT_bfs_open: rc=-11

Pogorszenie wydajności. Operacje odczytu lub zapisu (kopia zapasowa lub przywracanie) stają się powolne.

Causa

  • Oprogramowanie lub aplikacje skanera zabezpieczeń zainstalowane na komputerze skanują punkt montowania Boostfs wraz z innymi dyskami i folderami
  • BoostFS nie zaleca wielu aplikacji, w tym skanerów zabezpieczeń, aby uzyskać dostęp do punktu montowania BoostFS jednocześnie.
  • Może to doprowadzić do awarii w zależności od charakteru dostępu, ponieważ w BoostFS utrzymywany jest pojedynczy kontekst plików.
  • Ponadto oprogramowanie antywirusowe/skanera zabezpieczeń może uniemożliwić niektóre operacje związane z systemem plików.

Triaging:

sprawdź komunikaty dziennika "app-info" w Boostfs. Zostanie on uzupełniony nazwami oprogramowania antywirusowego/skanera zabezpieczeń. Tutaj "s1-agent" i "s1-fanotify" to nazwy aplikacji skanera bezpieczeństwa
ddboostfs_0_0.log:265760:Apr 21 16:51:09.048 26822 1603430144 [D] bfs_get_app_info: app_info=s1-agent
ddboostfs_0_0.log:266094:Apr 21 16:51:10.102 26822 1603430144 [D] set_conn_app_info: app_info=s1-agent
Feb 24 19:52:46.803 423080 2394937088 [D] bfs_get_app_info: app_info=s1-fanotify
Oznacza to, że oprogramowanie skanera korzysta z punktu montowania Boostfs.

Sprawdź aplikację w połączeniach DDBOOST wyszczególnione w DD ASUPs
DDBOOST Connections Detailed with-fips-mode
----------------------------Active Clients: 5Clients:
Client                             Idle   CPUs   Memory(MiB)    Plugin Version                                                 OS Version                                Application Version   Encrypted   DSP   Transport     FIPS mode
--------------------------------   ----   ----   -----------   ---------------   --------------------------------------------------------   ------------------------------------------------   ---------   ---   ---------   -----------

c3po01                    YES      14        64,152   7.7.4.0-1017373                 Linux 4.1.12-124.67.3.el7uek.x86_64 x86_64        BOOSTFS:7.7.4.0-1017610 FUSE:2.9.4 s1-agent          NO   YES        IPv4            NO

Na koniec sprawdź ustawienia aplikacji skanera, jeśli zawiera on punkty montowania/zamontowane dyski Boostfs.

Resolução

Zaleca się wykonywanie skanowania antywirusowego poza oknem programu Boostfs.

Sprawdź, czy można zmodyfikować ustawienia aplikacji skanera bezpieczeństwa, aby wykluczyć punkty montowania Boostfs ze skanowania i wszelkie inne wykonywane przez nią operacje.

Mais informações

  1. Ten artykuł dotyczy wszystkich wersji Programu BoostFS niezależnie od zainstalowanego na nim oprogramowania do skanera zabezpieczeń.
  2. Zgłoszone problemy dotyczą wielu skanerów zabezpieczeń, w tym Carbon-Black, McAfee, Fanotify, s1-agent, CrowdStrike i innych.

Produtos afetados

Data Domain
Propriedades do artigo
Número do artigo: 000215701
Tipo de artigo: Solution
Último modificado: 26 jan. 2024
Versão:  4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.