NetWorker vProxy-Backup schlägt mit "RPC error: Failed to connect to host " und "Err: 5037-Cannot resolve IP address from Host "
Resumo: Die NVP-Integration (NetWorker VMware Protection) wird mit der vProxy-Appliance konfiguriert. Die vProxy-Bereitstellung hatte einige Probleme mit der Namensauflösung und DNS. Die BACKUPS der virtuellen Maschine (VM) für einige virtuelle Maschinen schlagen mit einer Fehlermeldung zur ungültigen Namensauflösung fehl. ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
In der Datei /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:
Von /nsr/logs/daemon.raw:
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR: [1268:7F4794001E30] ddp_connect_with_config_internal() failed, Hostname: 110DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR: [1268:7F4794001E30] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR: [1268:7F4778001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR: [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
---- Skipping Lines ----
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T13:59:20Z ERROR: [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:06:29Z INFO: [1268:7F476C001C80] ddcl_nfs_open_tcp - Timed out trying to resolve the hostname: DD###_T4
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR: [1268:7F476C001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR: [1268:7F476C001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
Von /nsr/logs/daemon.raw:
71193 MM/DD/YYYY HH:MM:SS AM 0 0 0 4988 4616 0 my_networker_server nsrd NSR info Media Info: Failed to start nsrsnmd on host my_storagenode_name, error `RPC error: Failed to connect to host 'my_storagenode_name': Remote system error - No connection could be made because the target machine actively refused it.
Siehe Dell Artikel 22793, NetWorker: Verwenden von nsr_render_log
Causa
Problem mit der Namensauflösung auf vProxy-Hostebene
Resolução
Fügen Sie ip address, FQDN, Short Name of vCenter, Data Domain, NetWorker und Storage Node manuell in /etc/hosts of vProxy Host hinzu.
Starten Sie jetzt vProxy-VM-Backups.
Starten Sie jetzt vProxy-VM-Backups.
- Melden Sie sich bei der vProxy PuTTY-Sitzung als Administrator an und wechseln Sie dann zum Root-Benutzer:
sudo su - root
- Führen Sie den folgenden Befehl aus, um einen /etc/host-Eintrag zu erstellen.
# echo "IP_of_vCenter FQDN_of_vCenter ShortName_of_vCenter" >> /etc/hosts
BEISPIEL:
# echo "10.10.10.10 myvcenter.abc.com myvcenter" >> /etc/hosts
# echo "IP_of_DD FQDN_of_DD ShortName_of_DD" >> /etc/hosts
# echo "IP_of_NWServer FQDN_of_NWServer ShortName_of_NWServer" >> /etc/hosts
# echo "IP_of_StorageNode FQDN_of_StorageNode ShortName_of_StorageNode" >> /etc/hostsProdutos
NetWorker FamilyPropriedades do artigo
Número do artigo: 000219162
Tipo de artigo: Solution
Último modificado: 23 out. 2024
Versão: 3
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.