NVP-vProxy: Continuous login errors from vProxy
Resumo: NVP-vProxy: Continuous login errors from vProxy: Cannot complete login due to an incorrect username or password.
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
Continuous login errors from one vProxy to a vCenter are seen in the vbackupd.engine.log when debug is enabled. The error occurs every 5 minutes.
2024-07-18T14:02:54Z INFO: Request #83: Deleted resource: vCenter.com:vm-xxxxxx - xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. 2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: establish connection 2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: get channel 0 2024-07-18T14:02:54Z TRACE: Request #83: Reply sent successfully for 'DeleteSession'. 2024-07-18T14:02:54Z TRACE: Purged 0 aged files in '/opt/emc/vproxy/runtime/logs/recycle/daemon'. 2024-07-18T14:02:56Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 2024-07-18T14:06:18Z DEBUG: Session keepalive on vCenter 'vCenter.com' 2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sending 1 requests to scrubber ... 2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sent requests to scrubber. 2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Scrubber: Received 1 requests to scrub. 2024-07-18T14:07:52Z TRACE: CleanupMgr: vCenter.com: Scrubber: Logging into vCenter 'vCenter.com' 2024-07-18T14:07:55Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 2024-07-18T14:11:18Z DEBUG: Session keepalive on vCenter 'vCenter.com'
Causa
The vProxy's InventorySessions.gob files are used to store session information for the NetWorker server's nsrvisd service. The .gob extension suggests that these files are in the Go Binary format which may contain session information related to inventory management. In some instances, this file may not have been cleaned up and has cached outdated information about the vCenter credentials. In some instances, the InventorySessions.gob file may fail to be deleted during cleanup resulting in failed login attempts.
Resolução
Renaming the folder /data01/runtime/state/vbackupd/ folder or deleting the .gob file is the suggested workaround.
1. Open an SSH session to the vProxy appliance and login as admin.
2. Once logged in, switch to root:
6. Start vbackupd:
A new /data01/runtime/state/vbackupd/ directory is created.
1. Open an SSH session to the vProxy appliance and login as admin.
2. Once logged in, switch to root:
sudo su - 3. Stop the vbackupd service:
systemctl stop vbackupd 4. Rename the /data01/runtime/state/vbackupd/ directory:
mv /data01/runtime/state/vbackupd/ /data01/runtime/state/vbackupd_`date -I`.bak 5. Reload the vProxy daemons:
systemctl daemon-reload
systemctl start vbackupd
Mais informações
Ensure the vProxy appliances deployed are up to date on the latest major release supported by the NetWorker server:
NVP vProxy: How To Upgrade the NVP vProxy Appliance Using nsrvproxy_mgmt.
NVP vProxy: How To Upgrade the NVP vProxy Appliance Using nsrvproxy_mgmt.
Propriedades do artigo
Número do artigo: 000227670
Tipo de artigo: Solution
Último modificado: 12 ago. 2024
Versão: 1
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.