Geri yüklenen bir dosya yolu Maksimum Yol Uzunluğu Sınırlaması'nı (MAX_PATH) aştığında Windows Vmware dosya düzeyi geri yüklemesi (FLR) başarısız oluyor

Den här artikeln gäller för Den här artikeln gäller inte för Den här artikeln är inte kopplad till någon specifik produkt. Alla produktversioner identifieras inte i den här artikeln.

Symptom



Dosya düzeyinde geri yükleme işi, derin özyineleme ile belirli dizin yolunda başarısız oluyor.      FLR günlüklerinde genel hata günlükleri gösterilir 

 
--------------------------------------------------------------------------------------------------------
-----  START avvmwfile log <timestamp> UTC  [18.2.100-134 Linux-x86_64]
--------------------------------------------------------------------------------------------------------

<timestamp> avvmwfile Info <5008>: Logging to /usr/local/avamarclient/var/MOD-1565970042058-<cid>-3019-vmwfilew.log
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfile.cmd
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfileAll.cmd
<timestamp> avvmwfile Info <6673>: CTL listening on port 34258
<timestamp> avvmwfile Info <10684>: Setting ctl message version to 3 (from 1)
<timestamp> avvmwfile Info <16136>: Setting ctl max message size to 268435456
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfile.cmd
<timestamp> avvmwfile Info <5174>: - Reading /usr/local/avamarclient/var/avvmwfileAll.cmd
<timestamp> avvmwfile Info <19660>: targetlist contains <dir backup="true" date="1969-01-01 00:00:00" internal="0" group="unknown" protection="drwx------" name="C:/DFS_Shares/Users/Bob" size="65536" saveas="C:/DFS_Shares/users/restore" user="unknown" />

<timestamp> avvmwfile Error <0000>: Failed to restore files via network, check proxy log for details
<timestamp>  avvmwfile Error <0000>: assist_restore error. ret: 157

--------------------------------------------------------------------------------------------------------
----- END avvmwfile log <timestamp> UTC  (0 warnings, 2 errors, 0 fatal errors)
--------------------------------------------------------------------------------------------------------

 

Orsak

Sanal makinenin içinde Microsoft Windows, çok derin dosya ağacı yapılarına sahip DFS (Dağıtılmış Dosya Sistemi) ile yapılandırılmıştır. 

Orijinal konuma geri yükleme seçeneği kullanıldığında proxy'de FLR komut dosyası günlüğünü (/usr/local/avamarclient/bin/logs/flr*.err) şu şekilde görüntüleriz:
 
>file name: file1.txt
>file name: files2 
>file name: <long-file>-example.txt
>fail to create file  C:\DFS_Shares\users\restore\folder1\folder2\folder3\....< file length bigger than 260 characters>-example.txt  error code:2

Sorun: Maksimum Yol Uzunluğu Sınırlaması (MAX_PATH) aşıldı.  Varsayılan olarak bu sınır 260'tır ve kaydetme konumu ve dosya adı yolu kombinasyonu 260 karakterden


büyükse geri yükleme dosyası oluşturma sorununa neden olur Bu Microsoft sayfasında daha fazla bilgi mevcuttur: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

"Windows API'sinde (aşağıdaki paragraflarda tartışılan bazı istisnalar dışında), bir yol için maksimum uzunluk 260 karakter olarak tanımlanan MAX_PATH'dir.
Yerel yol şu sırada yapılandırılır: sürücü harfi, iki nokta üst üste, ters eğik çizgi, ters eğik çizgilerle ayrılmış ad bileşenleri ve sonlandırıcı null karakter"

Upplösning


1. Daha yeni Windows işletim sistemlerinde (Windows 10, Sürüm 1607 ve sonraki sürümler) Uzun Yolları Etkinleştir seçeneğini etkinleştirin.     
Aşağıdaki Microsoft KB sinde talimatlar verilmiştir: https://docs.microsoft.com/en-us/windows/win32/fileio/naming-a-file

VEYA

2. Orijinal konuma geri yüklemek yerine dizin yolunu kısaltmak için yeniden yönlendirilmiş bir geri yükleme gerçekleştirin. 
Örnek: genel dosya yolunu azaltan c:\restore\.  

Berörda produkter

Avamar

Produkter

Avamar, Avamar Client for VMware
Artikelegenskaper
Artikelnummer: 000053607
Artikeltyp: Solution
Senast ändrad: 09 okt. 2024
Version:  3
Få svar på dina frågor från andra Dell-användare
Supporttjänster
Kontrollera om din enhet omfattas av supporttjänster.