ECS:S3キー セルフサービスのドメイン属性のコンマ区切り値が機能しない
Sammanfattning: S3キー セルフサービスのドメイン属性のコンマ区切り値が機能していません。
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Symptom
お客様は、AD属性「sAMAccountName」を使用してログイン(そして最終的にはS3セルフサービス キーを作成)できるようにすることで、管理をシンプルにしようとしています。
これはネームスペース レベル(ネームスペースの管理 > )で構成されます。
2つのコンマ区切り値が構成されると、キー のセルフサービスが失敗し、次のエラーが表示されます。
個別に使用されている場合(1つの値のみを設定)、それぞれが動作しています。
最初のログインは、エントリーが1つだけ(トークンが作成される)場合です。
これはネームスペース レベル(ネームスペースの管理 > )で構成されます。
2つのコンマ区切り値が構成されると、キー のセルフサービスが失敗し、次のエラーが表示されます。
個別に使用されている場合(1つの値のみを設定)、それぞれが動作しています。
最初のログインは、エントリーが1つだけ(トークンが作成される)場合です。
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD" HTTP/1.1 200 OK Date: Fri, 17 May 2019 07:57:29 GMT Content-Type: application/xml Content-Length: 0 Connection: keep-alive X-SDS-AUTH-TOKEN: BAAcbmZXWHBVcVh5U2UrNjY3YkFkNnJuRHV5a2xzPQMAjAQASHVybjpzdG9yYWdlb31YzNkMWYzYzRjMwIADTE1NTgwMzE5NjQyODMDAC51cm 46VG9rZW46Y2MzNTMwMT1M6VmlydHVhbERhdGFDZW50ZXJEYXRhOjFmMTQyOTExLTM4NzktNGI3OC1hYWFkLTItMjA4Mi00OTRiLTlhMWUtOWRkZjBlMDQ2NjIwAgAC0A8= The second one is when there is a comma separated values (not working, HTTP 500 Error):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD" HTTP/1.1 500 Internal Server Error Date: Fri, 17 May 2019 07:57:49 GMT Content-Type: text/html;charset=iso-8859-1 Content-Length: 261 Connection: keep-alive Cache-Control: must-revalidate,no-cache,no-store Third login is again only one entry, the 2nd one (a Token is created again):
[user@client ~]$ curl -I -s https://$MANAGEMENT_ENDPOINT/login -u "$MANAGEMENT_USER:$MANAGEMENT_PASSWORD" HTTP/1.1 200 OK Date: Wed, 22 May 2019 12:25:32 GMT Content-Type: application/xml Content-Length: 0 Connection: keep-alive X-SDS-AUTH-TOKEN: BAAcWXV2QXpjTDVnd016dW9Tc3hWWXd6NUI4elBvPQMAjAQASHVybjpzdG9yYWdlb31YzNkMWYzYzRjMwIADTE1NTg0NjM5NjQzNzEDAC51cm 46VG9rZW46Nzc0NDI1MmUt1M6VmlydHVhbERhdGFDZW50ZXJEYXRhOjFmMTQyOTExLTM4NzktNGI3OC1hYWFkLTIDQyNi00OGRlLWFhMTctNjMzZmNiNzY0NTJhAgAC0A8=
Orsak
ドメイン属性でコンマ区切りの値が使用されている場合、問題が検出され、S3キー セルフサービスが期待どおりに機能しません。
Upplösning
この問題の根本原因は不明であり、Dell ECS開発による調査中です。
この問題を軽減するための回避策は、ECSを使用しているユーザーを追加できるActive Directory(AD)グループを作成することです。
AD管理者またはチームに連絡して、使用できるADグループを作成し、適切なすべてのユーザーが追加されていることを確認します。
このグループをECSに追加するには、次の手順を実行します。
ECSネームスペースをグループで構成した後、ECSに変更を加えることなく、ADグループを使用してユーザーを追加または削除できます。
この問題を軽減するための回避策は、ECSを使用しているユーザーを追加できるActive Directory(AD)グループを作成することです。
AD管理者またはチームに連絡して、使用できるADグループを作成し、適切なすべてのユーザーが追加されていることを確認します。
このグループをECSに追加するには、次の手順を実行します。
- manage - namespace ->> edit を選択します。
- まだ完了していない場合は、[Domain]をクリックします。
- グループ名を グループ フィールドに追加します。属性は不要なので、[attributes]フィールドの横にある[X]をクリックすると閉じます。
- 「Save(保存)」をクリックします。
ECSネームスペースをグループで構成した後、ECSに変更を加えることなく、ADグループを使用してユーザーを追加または削除できます。
Ytterligare information
Berörda produkter
ECS ApplianceProdukter
ECS Appliance, Elastic Cloud StorageArtikelegenskaper
Artikelnummer: 000056273
Artikeltyp: Solution
Senast ändrad: 13 feb. 2023
Version: 3
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