AppSync: SQL kimlik doğrulaması, SQL için bağlantı kimlik bilgilerini değiştirdikten ve ardından bir veya birkaç başarılı çalıştırmadan sonra başarısız olur.

Den här artikeln gäller för Den här artikeln gäller inte för Den här artikeln är inte kopplad till någon specifik produkt. Alla produktversioner identifieras inte i den här artikeln.

Symptom

SQL bağlantısının parolası değiştirilmiştir.
Bu makalede verilen örnekte, parola 7 alfasayısal karakterden/simge karakterden 12 olarak değiştirilmiştir. 
Bu değişikliğin ardından Hizmet Planı iki kez sorunsuz çalıştı ancak bu makalede belgelendiği üzere üçüncü çalıştırmada başarısız oldu.

SQL bağlantısı için kimlik bilgilerini değiştirdikten sonra, hizmet planı bir veya birkaç kez başarıyla çalışabilir.
Ancak bir veya birkaç başarılı çalıştırmadan sonra hizmet planı aşağıdaki hatalarla başarısız olur:

 AppSync CSV olaylarında şunlar gösterilir:
 
2019-10-10 09:52:02.18, Uygulama keşfi, ,GENL_000003,kaynak< ana bilgisayar,Sağlanan> kimlik bilgileri kullanılarak kimlik doğrulaması yapılamadı.
 Kimlik bilgilerinin doğru olduğunu ve hesabın gerekli hak ve ayrıcalıklara sahip olduğunu doğrulayın.
 Ek bilgiler: Oturum açma hatası: bilinmeyen kullanıcı adı veya hatalı parola.

Kaynak ana bilgisayar AppSync Eklentisi günlüğünde şunlar gösterilir:
 
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unique number>] SQL: Connecting to database <DBName.master
> 2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unique number>] SQL: impersonating <Domain\User>
2019-10-10 09:52:05.228 ERROR [<sourcehost>] [<unique number>] SQL: Sağlanan kimlik bilgileri kullanılarak kimlik doğrulaması yapılamadı. Kimlik bilgilerinin doğru olduğunu ve gerekli hak ve ayrıcalıklara sahip olduklarını doğrulayın. Ek bilgiler: Oturum açma hatası: bilinmeyen kullanıcı adı veya hatalı parola.

AppSync Sunucusu günlüğünde şu mesaj gösterilir:
 
10-10-2019 09:52:00.805 INFO [Thread-3009 /id<>domain><Domain></domain<>password<>/password><username<>User></username></credentials
<>
10-10-2019 09:52:02.180 ERROR [Thread-3009 (HornetQ-client-global-threads-216778052)] [org.jboss.as.ejb3.invocation] [] [] WFLYEJB0034: EJB Çağrısı, public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice yöntemi için SqlServiceBean bileşeninde başarısız oldu. <kaldırıldı>... HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException

Not: Yeni parola farklı sayıda alfasayısal karakterler/özel karakterler içeriyorsa, ilk veya birkaç başarılı çalıştırma sunucu günlüğünde farklı sayıda yıldız işareti gösterebilir. Parolanın 7 alfanümerik/özel karakterden 12 karaktere değiştirildiği aşağıdaki örnekte olduğu gibi.
 
10-10-2019 09:15:05.704 INFO [Thread-2952 /id><domain>MESSA</domain><password<>/password><username>User</username></credentials
<> 

 
Ardından, sonraki bir başarısız çalıştırmada parolanın daha kısa olduğuna dikkat edin:
 
10-10-2019 09:52:00.805 INFO [Thread-3009 /id<>domain><Domain></domain<>password<>/password><username<>User></username></credentials
<>

Orsak

AppSync in kimlik bilgilerini güncellemesine neden olan yazılım hatası, hizmet planının çalıştırıldığı ikinci ve uygun olmayan bir zamanda kullanılır.

Upplösning

Çözüm:

AppSync 3.8 için bu sorunu çözecek bir düzeltme mevcuttur.

Sorunla ilgili bir servis isteği gönderirken bu makaleden alıntı yapın.

Berörda produkter

AppSync

Produkter

AppSync
Artikelegenskaper
Artikelnummer: 000168662
Artikeltyp: Solution
Senast ändrad: 19 aug. 2025
Version:  4
Få svar på dina frågor från andra Dell-användare
Supporttjänster
Kontrollera om din enhet omfattas av supporttjänster.