SQL Server hizmeti (MSSQLSERVER) Başlatılamıyor

Sammanfattning: Microsoft SQL Server hizmeti (MSSQLSERVER) bozuk bir veritabanı nedeniyle başlatılamayabilir. Bu makalede, bu sorunu giderme işlemi gösterilmektedir.

Den här artikeln gäller för Den här artikeln gäller inte för Den här artikeln är inte kopplad till någon specifik produkt. Alla produktversioner identifieras inte i den här artikeln.

Symptom

Microsoft SQL Server hizmeti (MSSQLSERVER) başlatılamıyor. Error 7024 (kaynak: Hizmet Kontrol Yöneticisi), SQL'in yüklü olduğu sunucunun Sistem olay günlüğünde görünür.

Orsak

Bu hizmet birden çok nedenden dolayı başlatılamayabilir ve bu makalede bir konu ele alınmaktadır: bozuk bir veritabanı.

Upplösning

Herhangi bir hizmet başlatılamadığında, Hizmet Denetim Yöneticisi bu hizmeti barındıran sunucunun Sistem olay günlüğüne bir hata kaydeder. Bu olay (bu durumda kimlik 7024), sorunu gidermek için yeterli ayrıntı sağlayabilir veya sağlamayabilir. SQL Server hizmetiyle ilgili bir sorunu giderirken SQL hata günlüğü büyük olasılıkla daha yararlı bilgiler içerir.

SQL hata günlüğünü bulmak için şu adımları izleyin:
  1. SQL Server Configuration Manager'ı başlatın.
  2. Sol bölmeden SQL Server Services öğesini seçin.
  3. Orta bölmede SQL Server'a (MSSQLSERVER) sağ tıklayın ve Özellikler'i seçin.
  4. Özellikler penceresinde Başlangıç Parametreleri sekmesini seçin.
  5. Existing parameters alanında, -e ile başlayan giriş hata günlüğünün yolunu içerir.
Dosya Gezgini'nde yukarıda verilen yola göz atın. Uzantısı olmayan ERRORLOG dosyası, geçerli hata günlüğüdür. (Sayısal uzantılara sahip ERRORLOG dosyaları daha eski günlüklerdir.) Geçerli günlük dosyasını Not Defteri'nde açın ve dosyanın sonuna gidin. Günlükteki son giriş, hizmet hatasının nedenini belirten bir hata olmalıdır.

Bozuk bir veritabanı aşağıdakine benzer bir hatayla gösterilebilir:

SQL Server mantıksal tutarlılık tabanlı bir G/Ç hatası algıladı: Yanlış sağlama toplamı

Hata mesajı, sorunun hangi veritabanında yaşandığını da gösterir. SQL hizmetlerinin başlatılması için gereken üç sistem veritabanı vardır: ana veritabanı, model veritabanı ve tempdb. Hata büyük olasılıkla bu veritabanlarından birinden bahseder.

Ana veritabanındaki bozulma sorun ise önerilen çözüm, veritabanını bir yedekten geri yüklemektir.

Sebep model veritabanındaki bozulma ise, SQL Server Model Veritabanı Onarımı'nda bir onarım prosedürü bulunabilir.

Model veritabanı sağlam olduğu sürece SQL Server hizmeti her başlatıldığında tempdb veritabanı yeniden oluşturulur.

Berörda produkter

Prosupport for Microsoft Software
Artikelegenskaper
Artikelnummer: 000223030
Artikeltyp: Solution
Senast ändrad: 23 jan. 2025
Version:  3
Få svar på dina frågor från andra Dell-användare
Supporttjänster
Kontrollera om din enhet omfattas av supporttjänster.