PowerFlex-hanteringsplattform: Gatewayresursen visar att PowerFlex inte kan nås
Sammanfattning: PowerFlex Gateway-resursen visar en varning om att PowerFlex-systemet inte kan nås.
Symptom
Scenario
PowerFlex-backend-systemet använder fortfarande 3.x-programvaran och importerades till PowerFlex Manager 4.x-systemet.
Påverkan
Det gick inte att genomföra en lyckad PowerFlex Gateway-uppgradering.
Orsak
I PowerFlex Manager finns det två gatewaypoddar som ansvarar för begäranden om belastningsutjämning. När backend-systemet är på version 3.x använder gatewayen en token för autentisering med MDM. Autentiseringstoken lagras dock bara på en av gatewayerna. När flera på varandra följande anrop görs kan belastningsutjämningsfunktionen därför dirigera vissa anrop till gatewayen utan inloggningstoken, vilket gör att dessa anrop misslyckas. Det här felet resulterar i att gatewayresursen varnar om att PowerFlex-systemet inte kan nås.
Upplösning
Släpp ReplicaSet för PowerFlex-gatewayerna till en enda gateway:
-
SSH till någon av PowerFlex Management Platform-värdarna
-
Släpp replikerna ned till 1:
kubectl scale sts block-legacy-gateway -n powerflex --replicas=1
-
Utför gatewayuppgraderingen. Detta uppgraderar systemet till 4.x där MTLS används och detta problem observeras inte.
-
När PowerFlex-backend-systemet har uppgraderats till 4.x justerar du tillbaka replikeringsuppsättningen till 2 för gatewayen:
kubectl scale sts block-legacy-gateway -n powerflex --replicas=2
Berörd version
PowerFlex Manager 4.x
Åtgärdat i version
PowerFlex Manager 4.6.1