Avamar: Il ripristino del file system di Windows ha esito negativo con "Unable to BackupWrite" e "The data is invalid"

摘要: Il ripristino del file system di Windows ha esito negativo con errori: Errore Avtar <5737>: I/O ed errore: Impossibile eseguire BackupWrite(4) "D:Temp_file_name_.xlsx" (codice 13: Dati non validi). Questo articolo affronta il problema "codice 13: The data is invalid" che può essere visualizzato durante un'operazione di ripristino Avamar. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Il processo di ripristino di alcuni file .xlsx e .pdf ha esito negativo con i seguenti errori nel file di registro:
2017-01-18 11:34:54 avtar Error <5737>: I/O error: Unable to BackupWrite(4) "D:\Temp\_file_name_.xlsx" (code 13: The data is invalid).
2017/01/18-10:34:54.05100 [avtar]  restdata: BackupRead content is valid
2017-01-18 11:34:54 avtar Error <5189>: Error restoring path "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" to "D:\Temp\".
2017-01-18 11:34:54 avtar Error <5263>: Restore of "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" failed

I file interessati vengono ripristinati, ma Excel o Acrobat Reader non possono aprire i file poiché sembrano danneggiati.

Esempio di messaggio di errore quando si tenta di aprire il file:

"Excel cannot open the file 'filename.xlsx' because the file format for the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."

Altri file .xlxs o .pdf dello stesso processo di ripristino vengono ripristinati e possono essere aperti.

原因

Questo comportamento è dovuto a una combinazione di file ripristinati con intestazioni file diverse, NTFS e FAT32, a una partizione NTFS dallo stesso processo di ripristino.

I file menzionati negli avvisi hanno un'intestazione di file FAT32. Questi file sono stati creati su un vecchio server Windows 2003 con partizioni FAT32 e quindi spostati su un sistema con partizioni NTFS.

解决方案

Questo problema è stato identificato come un problema di codice nel binario avtar ed è già stato risolto. Le versioni correnti di Avamar non dovrebbero riscontrare questo problema.

Se il problema viene riscontrato in una qualsiasi delle versioni correnti di Avamar, è possibile risolverlo con questi passaggi:
  1. Prima dell'operazione di ripristino, aggiungere il flag --x06=4096 nel file avtar.cmd nel percorso dell'agent <client-install-folder>\var.
  2. Eseguire il ripristino di tali file FAT32, quindi rimuovere il flag dopo il ripristino.
 
Nota:
  • Il flag è stato progettato per ripristinare i file con intestazioni FAT32 in una partizione NTFS.
  • Tale flag può essere utilizzato solo per i tipi di file FAT32 e non riesce a ripristinare i tipi di file NTFS.
  • Una volta completato il ripristino del file FAT32, il flag deve essere rimosso dal file avtar.cmd e riutilizzato solo quando necessario.

受影响的产品

Avamar

产品

Avamar, Avamar Client for Windows
文章属性
文章编号: 000054812
文章类型: Solution
上次修改时间: 09 10月 2024
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。