NVP vProxy : Échec de la sauvegarde de la machine virtuelle avec « le snapshot a déjà été supprimé ou n’a pas été entièrement créé »

摘要: Échec de la sauvegarde de la machine virtuelle avec « le snapshot a déjà été supprimé ou n’a pas été entièrement créé »

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

  • Les sauvegardes de machines virtuelles effectuées avec l’appliance NVP vProxy signalent l’erreur suivante :
YYYY-MM-DDTHH:mm:SSZ ERROR: Request to remove snapshot 'snapshot-#####' on VM 'VM_NAME' was rejected by vCenter 'VCENTER_NAME': ServerFaultCode: The object 'vim.vm.Snapshot:snapshot-#####' has already been deleted or has not been completely created

原因

Il y avait d’anciens fichiers de snapshot dans le datastore pour cette machine virtuelle.

解析度

L’utilitaire ProxyHC peut être utilisé pour nettoyer les disques et les snapshots restants. 

Pour effectuer un nettoyage manuel dans VMware, procédez comme suit :
  1. Connectez-vous au client Web vSphere.
  2. Cliquez avec le bouton droit de la souris sur la machine virtuelle et sélectionnez Snapshots-> Delete All Snapshots.
  3. Cliquez avec le bouton droit de la souris sur la machine virtuelle et sélectionnez Snapshots-Consolidate>.
  4. Sélectionnez l’onglet Datastores et accédez au répertoire de la machine virtuelle, puis recherchez les fichiers de snapshot. Si des fichiers de snapshot résident ici, supprimez-les.
  5. Si aucun snapshot n’est trouvé, mais que le problème persiste, essayez de créer un snapshot à partir de VMware.
NOTE:Si la machine virtuelle effectue des sauvegardes cohérentes avec les applications (MSVMAPPAGENT), effectuez un snapshot mis en veille ; sinon, effectuez un snapshot non mis en veille.
  1. Répétez les étapes 2 à 4 pour vous assurer que les fichiers de snapshot sont supprimés.
  2. Exécutez une sauvegarde.

Au début des sauvegardes de machine virtuelle, le vProxy demande au vCenter de créer un snapshot pour la machine virtuelle. Une demande est envoyée à la fin de la sauvegarde pour supprimer le snapshot. Le serveur vCenter crée, gère et supprime les fichiers de snapshot. Si ce problème persiste ou qu’une erreur se produit au cours de l’une des étapes ci-dessus, contactez le support VMware pour obtenir de l’aide.

受影響的產品

NetWorker

產品

NetWorker
文章屬性
文章編號: 000172495
文章類型: Solution
上次修改時間: 28 5月 2025
版本:  4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。