Dell Unity: 240일 이상 작동 후 SP 패닉

摘要: Dell Unity XT 480, 680 또는 880 SP(Storage Processor)를 240일 이상 가동하면 패닉이 발생할 수 있습니다. (Dell 수정 가능)

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Dell Unity XT 480, 680 또는 880 SP를 240일 동안 가동한 후 패닉이 발생할 수 있습니다.  다른 Dell Unity 시스템은 240일 이상(즉, 730일 이상) 후에 문제가 발생할 수 있습니다.

UDotor는 SP가 240일 이상 실행된 5.3 미만의 코드 버전에 대해 알림을 생성할 수 있으며 해당 알림은 이 KB 문서를 참조합니다.  KB 문서 Dell Unity: SP(Storage Processor) 가동 시간 패닉 수정이 이미 적용된 OE 5.2.1 이상에서 중요 알림 640003 발생하여 UDoctor 알림에 대한 자세한 내용을 참조하십시오.

原因

정수 오버플로 계산으로 인해 64비트 결과가 32비트 변수에 저장되어 SP 패닉이 발생할 수 있습니다. 

이 문제는 Unity OE 버전 5.1.0.0.5.394부터 5.2.0.0.5.173까지를 실행하는 Unity XT 480, 680 또는 880 어레이에서 발생할 가능성이 가장 높습니다 . 이는 해당 코드 및 해당 모델에 사용되는 SP 하드웨어 내의 변경 사항과 코드가 해당 하드웨어와 상호 작용하는 방식 때문입니다.

 

참고: 이전 코드 및 Unity 모델에서는 이 문제가 발생할 가능성이 지만, 특히 SP가 240일 이상(즉, 730일 이상) 실행된 경우 이전 코드 또는 이전 Unity 모델에서 문제가 발생할 수 있습니다.

 

참고: 이 문제로 인해 SP 재시작이 트리거되기 전의 평균 일 수는 275-300일입니다. 275일 전에 SP를 재시작할 있지만 가능성은 적습니다. 이 문제로 인한 스토리지 프로세서 재시작이 240일 이전에는 발생하지 않습니다.

解析度

수리하다:
이 수정 사항은 Unity OE 버전 5.2.1.0.5.013 이상에서 사용할 수 있습니다.  그러나 이 코드 버전으로 업그레이드하는 것은 권장하지 않습니다.  Dell은 고객에게 사용 가능한 최신 코드로 업그레이드할 것을 적극 권장합니다. 또는 최소한 최신 코드가 "타겟" 코드가 아닌 경우에는 타겟 코드로 업그레이드하십시오.

또한 UDoctor 유틸리티는 Unity OE 버전 5.3 이하에서 이 문제를 식별합니다. 이는 수정 사항이 버전 5.3에서 제공 되었지만 5.2.1 이상의 코드로 백포트되었기 때문입니다.  UDoctor 경고는 백포트된 코드에서 트리거됩니다.


해결 방법:

SP 패닉을 방지하려면 240일마다 SP를 사전 예방적으로 재부팅하십시오. SP 재부팅 지침은 다음 문서에서 확인할 수 있습니다. Unity: 스토리지 프로세서를 재부팅하는 방법(사용자 수정 가능)

고객은 "uptime" SSH를 사용하여 어레이에 연결하고 서비스 계정을 사용하여 SP 런타임을 가져오는 명령입니다.

아래 예는 가동 시간이 31일임을 보여줍니다.

04:30:01 service@xxx spa:~/user# uptime
04:30am  up 31 days  3:41,  2 users,  load average: 29.21, 29.45, 29.51

 


 

위의 수정 사항이나 해결 방법이 구현되지 않는 한 UDoctor 알림은 3일마다 새로 고쳐집니다.  Dell Technologies는 고객에게 수정 사항 또는 해결 방법(수정 사항을 구현할 수 없는 경우)을 구현할 것을 권장합니다. 그러나 수정 사항이나 해결 방법을 구현할 수 없는 경우 이 조건에 대한 UDoctor 검사만 비활성화할 수 있습니다.

SSH를 사용하여 주 SP에 로그인하고 다음 명령을 실행합니다.

svc_udoctor --jobs --disable CalculateUptime

이렇게 하면 검사가 3일마다 실행되지 않습니다.

受影響的產品

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
文章屬性
文章編號: 000200921
文章類型: Solution
上次修改時間: 12 12月 2025
版本:  24
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。