Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell PowerStore Networking Guide for PowerStore T Models

Configure the Fail Safe Network on the switch

Network Attached Storage (NAS) is only supported with Unified deployments.

Ensure that the networks are applied to the uplink ports and port channels.

  1. Establish a terminal connection to the first ToR switch (Switch1).
  2. Enter global configuration mode.
    configure terminal
  3. Use the existing VLAN created for NAS traffic or create a new NAS VLAN.
    If using an existing VLAN, continue to step 4.
    interface vlan 500
    description NAS_network
    no shutdown
    exit
    
  4. Create the standby NAS LACP port-channel for Node A ports.
    interface port-channel 11
    description NodeA_NAS_standby_port_channel
    switchport mode trunk
    switchport trunk allowed vlan 500
    spanning-tree port type edge
    mtu 9216
    exit
  5. Use the existing NAS port channel or create a new NAS LACP port-channel for Node B ports.
    If using an existing port channel skip to step 6.
    interface port-channel 20
    description NodeB_NAS_active_port_channel
    switchport mode trunk
    switchport trunk allowed vlan 500
    spanning-tree port type edge
    mtu 9216
    exit
  6. Assign Node A ports to the LACP group.
    interface ethernet 1/1/14
    description NodeA_NASs_IOM_0_port1
    no shutdown
    channel-group 11 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
    
    interface ethernet 1/1/12
    description NodeA_NASs_IOM_1_port1
    no shutdown
    channel-group 11 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  7. Assign Node B ports to the LACP group.
    interface ethernet 1/1/8
    description NodeB_NASa_IOM_0_port3
    no shutdown
    channel-group 20 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
    
    interface ethernet 1/1/10
    description NodeB_NASa_IOM_1_port3
    no shutdown
    channel-group 20 mode active
    flowcontrol receive off
    flowcontrol transmit off
    mtu 9216
    exit
  8. Use the existing NAS VLANuplink configuration or configure the NAS VLAN for the uplink.
    If you have already configured the uplink, continue to step 9.
    interface port-channel 50
    switchport trunk allowed vlan 500
    exit
  9. Commit configuration changes to nvram.
    copy running-configuration startup-configuration
  10. Repeat steps 1 - 9 on the second ToR switch (Switch2) as demonstrated below.
    NOTE: Be sure to use the correct port channels and ethernet ports when configuring the second ToR switch (Switch2) as demonstrated below.
Table 1. Code sample for configuration NAS networks on the ToR swtiches
Switch 1 Switch 2
configure terminal

interface vlan 500
description NAS_network
no shutdown
exit

interface port-channel 11
description NodeA_NAS_standby_port_channel
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface port-channel 20
description NodeB_NAS_active_port_channel
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface ethernet 1/1/14
description NodeA_NASs_IOM_0_port1
no shutdown
channel-group 11 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/12
description NodeA_NASs_IOM_1_port1
no shutdown
channel-group 11 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/8
description NodeB_NASa_IOM_0_port3
no shutdown
channel-group 20 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/10
description NodeB_NASa_IOM_1_port3
no shutdown
channel-group 20 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface port-channel 50
switchport trunk allowed vlan 500

copy running-configuration startup-configuration
configure terminal

interface vlan 500
description NAS_active_network
no shutdown
exit

interface port-channel 10
description NodeA_NAS_active_port_channel
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface port-channel 12
description NodeB_NAS_standby_port_channel
switchport mode trunk
switchport trunk allowed vlan 500
spanning-tree port type edge
mtu 9216
exit

interface ethernet 1/1/45
description NodeA_NASa_IOM_0_port3
no shutdown
channel-group 10 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/47
description NodeA_NASa_IOM_1_port3
no shutdown
channel-group 10 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/43
description Nodeb_NASs_IOM_1_port1
no shutdown
channel-group 12 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface ethernet 1/1/41
description NodeB_NASs_IOM_0_port1
no shutdown
channel-group 12 mode active
flowcontrol receive off
flowcontrol transmit off
mtu 9216
exit

interface port-channel 50
switchport trunk allowed vlan 500
exit

copy running-configuration startup-configuration

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\