SupportAssist for PCs

Last reply by 03-14-2023 Solved
Start a Discussion
2 Bronze
2 Bronze

SupportAssist gives: An unexpected error occurred

Dell G15 5515 Ryzen Edition

This is a brand new laptop literally less than a week old. Trying to check for Drivers/Updates in SupportAssists gives the message: An unexpected error occurred. No error code or helpful information in the slightest, nothing in the logs that I can see or Event Viewer either. I can't check for updates from your site because you have it set to search through your broken program as well and it gives another similar vague error with no actual information.

I am not downloading and trying to resinstall it again. I've already done that twice and I"m on a highly limited bandwidth connection and we are already way over what we should be with far too many days in the billing month left. I cannot redownload this program yet again with so many other things to update still on top of it (and no I can't take it somewhere with WiFI as I live over 20 miles in the country and am dealing with serious health issues and can't leave due to this dumb pandemic).

In my searches online trying to find the issue I've found a massive amount of people with the exact same issue and mostly on the same version (, some of these issues going back months or longer. This is clearly a known issue so why is it not resolved after all this time still and how to I get this working on the laptop? Again, I'm not uninstalling and reinstalling a 3rd time to waste what precious little bandwidth I have left only to have it not work anyway. My WIndows Updates are fully up to date minus a preview update I have no interest in downloading yet.

Replies (13)

@lmacri wrote:

... Note that a few users have reported that a new SupportAssist v3.12.1.180 was recently pushed out to their system ...

Hi Atryeu1:

Just an FYI that I launched SupportAssist v3.11.4.29 on my Inspiron 5584 today and the auto-check for product updates installed a new v3.12.3.5.  The release notes for SupportAssist v3.12.3 have been posted at and the minimum system requirements <ADMIN NOTE: Broken link has been removed from this post by Dell> confirm that this new version requires .NET Core Runtime v6.0.x.

I posted some initial feedback about v3.12.3.5 in The Escaper's 08-Aug-2022 thread SupportAssist Get Drivers & Downloads Not Working, but so far things look okay.  If SupportAssist won't launch on your Dell G15 5515 Ryzen Edition see Dell employee DELL-Chris M's instructions for a clean reinstall at SA Uninstall / Reinstall.
64-bit Win 10 Pro v21H2 build 19044.2006 * Firefox v105.0.3 * Microsoft Defender v4.18.2207.7l-1.1.19600.3 * Malwarebytes Premium v4.5.14.210-1.0.1772 * Macrium Reflect Free v8.0.6979 * Dell SupportAssist v3.12.3.5 * Dell Update Windows Universal v4.6.0 * Inspiron 5583/5584 BIOS v1.21.0
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620


Hi Imacri, I appreciate the heads up earlier! I booted the laptop up this evening and there was the update for me as well and I was able to successfully run the driver/update check and it picked up my final updates I was missing still! I ran a Hardware Scan as well and can confirm it appears to be working now with no 'unexpected error' messages so hopefully this is the 2nd issue fixed finally now as well! I appreciate the responses and the heads up about the update finally releasing, thank you I'll mark your final post as the solution as it's hopefully fixed now.

I'd like to ask, you are not good by chance at deciphering Windows error log messages are you? Those still have me stuck. One (for AWCC) shows a faulting module of a Windows system file but the program is running okay when I load it. That error shows in the logs each time the laptop boots. There is another for another installed program on the laptop that comes up at boot time that seems to be an issue with itself but I'm struggling with both to find any helpful information online about either. The 3rd error has me at a loss as well but I can clearly see the issue, just no idea how to resolve it. In that case it's checking some MS file on the Azure site it seems that doesn't exist at the link it's attempting to access -_-  I'm stuck with those log errors and no ideas still how to go about them. If you have any experience with that I'd love to have you take a look, otherwise I'll continue my search for those elsewhere since they are not technically related to Dell (other than AWCC).

Thanks again for the help with SupportAssist, it was appreciated and I'm glad it was just the program itself being buggy and not another big issue to have to solve on my end.

2 Bronze
2 Bronze

I'm having this problem with v.  It last ran February 11 but since gives me an error.  I have done all the things suggested on this thread, but to no positive results.  I have uninstalled/reinstalled twice.  All Services are set to automatic/running.


@sandray1611 wrote:

I'm having this problem with v.  It last ran February 11 but since gives me an error.  I have done all the things suggested on this thread, but to no positive results...

Hi sandray1611:

This is an old thread from Sept 2022 about problems with SupportAssist v3.11.4.29, which had different minimum system requirements than the current version of SupportAssist v3.13.2.14 (released Feb 2023) - for example,the release notes <here> show that SupportAssist v3.13.0 now requires Microsoft .NET Runtime v6.0.9 or higher.

This old thread has already been marked as solved, so it would be helpful if you could start a new topic and let us know your Dell computer model, Windows operating system [if Win 10 or Win 11 please include the edition (e.g., Home Pro, etc.), version and OS build number shown at Settings | System | About | Windows Specifications], and what errors or warnings you see when you try to run SupportAssist v3.13.2.14.

Also let us know if Microsoft .NET Runtime v6.0.9 or higher is installed on your system at Control Panel | Programs | Programs and Features. From my Inspiron 5584 / Win 10 Pro v22H2 laptop, which shows that shows I currently have Microsoft .NET Runtime v6.0.14:

Win 10 Pro v22H2 Control Panel MS NET Runtimes Installed 09 Mar 2023.png

64-bit Win 10 Pro v22H2 build 19045.2604 * Firefox v110.0.1 * Microsoft Defender v4.18.2301.6-1.1.200000.2 * Malwarebytes Premium v4.5.24.248-1.0.1944 * Macrium Reflect Free v8.0.7279 * SupportAssist v3.13.2.14 * Dell Update for Windows Universal v4.7.1 * Inspiron 5583/5584 BIOS v1.22.1
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620

Latest Solutions
Top Contributor