Avamar: Linux/UNIXバックアップ エラー「開くことができないか、元のデータ サイズと一致しません」
概要: バックアップ中のファイルの変更または削除が原因で、Avamarバックアップが失敗し、「開くことができません」や「元のデータ サイズと矛盾しています」などのエラーが表示されます。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
Avamarバックアップ エラー
Avamarバックアップが例外を出して完了します。ログを確認すると、次のようなメッセージが表示されます。
- Avamarバックアップがファイルの読み取りエラーで失敗する
- エラーは「開くことができません」または「元のデータ サイズと一致しません」を示します
- バックアップ中にファイルが見つからない、または使用中と報告される場合がある
エラー メッセージの例は次のとおりです。
avtar Error <16507>: Path "/logs/tools/verbose.log": Total processed bytes 49347 is inconsistent with original data size 70715 avtar Error <5137>: Unable to open "/logs/tools/verbose.logbk" for backup (code 2: No such file or directory)
原因
問題の根本原因
Avamar UNIX/Linuxクライアントでは、バックアップ元のディスクのスナップショットは作成されません。代わりに、Avamarクライアントはディスクをスキャンし、バックアップするファイルのリストを作成します。バックアップ中に、見つかったファイルは最初に見つかったファイルと比較されます。ファイルの情報が異なる場合は、エラーがログに記録されます。
- 最初に検出された時刻からバックアップされた時刻の間にファイル サイズが変更されている可能性があります。
- ファイルは、最初に検出された後、バックアップされる前に削除された可能性があります。
- Avamarがファイルをバックアップしようとしたときにファイルが使用中であり、バックアップが実行されない場合があります。
これらの不一致により、バックアップが完了してリストアに使用できる場合でも、バックアップ プロセス中にエラーがログに記録される可能性があります。
解決方法
Avamar Linux/UNIXバックアップ エラーの解決
Avamar Linux/UNIXバックアップ エラーを解決するには、次の手順を実行します。
- バックアップ中に実行中のすべてのアプリケーションを停止します。
- 問題のあるファイルまたはファイルへのパスを除外します。
これらの方法は、バックアップ エラーを防止し、バックアップ プロセスを確実に成功させるのに役立ちます。
対象製品
Avamar製品
Avamar文書のプロパティ
文書番号: 000057579
文書の種類: Solution
最終更新: 15 8月 2025
バージョン: 4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。