Connectrix: Cisco MDS: 'PLATFORM-1-PFM_ALERT: FAN_BAD' incorrectly logging events for absent fans

Summary: Switch streaming "%PLATFORM-1-PFM_ALERT: FAN_BAD" related events for absent fans

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Issue was observed on switches running on 8.3(1).
  • The following events were streaming for absent fans: 

           %PLATFORM-1-PFM_ALERT: FAN_BAD: fan2 fan4

  • The output of #show environment depicts that the concerned fans are absent and not faulty.
Fan:
-----------------------------------------------------------------------------------------------------------------
Fan             Model                Hw         Status        Airflow direction        Fan Speed[Fan0-Fan1] (rpm)
-----------------------------------------------------------------------------------------------------------------
ChassisFan1     FAN Module 1         --         Ok              Back to Front               7142  -  5258
ChassisFan2     ----------           --         Absent          NA                                NA
ChassisFan3     FAN Module 3         --         Ok              Back to Front               7161  -  5263
ChassisFan4     ----------           --         Absent          NA                                NA
Fan_in_PS1      --                   --         Ok              Back to Front                     --
Fan_in_PS2      --                   --         Absent          NA                                --
Fan Air Filter : NotSupported

 

Cause

Cisco issue: CSCvm02193This hyperlink is taking you to a website outside of Dell Technologies.  (Log in to Cisco site is required)

Resolution

There is no workaround as this is a cosmetic error but it is a frequent issue. 

Verify if the fans are physically present or absent. If fans are absent, then upgrade the switch to 8.3(2) which has a fix for this issue. 


Additional Information

Cisco issue CSCvm02193 is listed under "Resolved caveats in Cisco MDS NX-OS Release 8.3(2)."
A copy of the release notes 8.X is attached to the KB for reference.

Affected Products

Connectrix MDS-9132T
Article Properties
Article Number: 000188724
Article Type: Solution
Last Modified: 18 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.