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Dell Unity: How to solve VMFS datastore administrative issues after OE upgrade. (User Correctable)

Summary: After upgrading Unity some administrative issues regarding the VMFS datastore can be noticed. 1. Failure or partial failure adding or removing datastore access to ESXi hosts through Unisphere. 2. From vCenter, it is not possible to see datastore name changes made from Unisphere. ...

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Article Content


Symptoms

The storage may have all or some of the following errors during adding/removing datastore in Unisphere:

1) Failed: Removing host access from the datastore partially failed.
   (Error Code: 0x5c00107).

   Rollback Result: Task was rolled back and marked as failed.
   This is because some tasks failed or SP rebooted during task execution. (Error Code: 0x100a).

2) Failed: Adding host access to the datastore partially failed.
   (Error Code: 0x5c00106).
   
   Rollback Result: Task was rolled back and marked as failed.
   This is because some tasks failed or SP rebooted during task execution.
   (Error Code: 0x100a).
   
NOTE: There is another issue that does not generate messages.
When the customer changes a datastore name at the Unity side, it does not reflect at the vCenter side. 

Cause

Unity upgrade caused the issues.

Resolution

To solve this issue, It is necessary to remove/delete vCenter registered at Unisphere, then add and register vCenter again to the Unisphere. 

In case you are running OE 5.3.x, and there are associated ESXi hosts you will not be able to proceed removing the associated vCenter from Unity Unisphere, unless you first remove all the associated ESXi hosts.


During this procedure there are no impacts to the ESXi hosts, and VMs that are accessing the Unity datastores, if you are using ONLY VMFS datastores. 

If vVol datastores are configured, do not perform this procedure, and contact support. 
vVol datastore changes cause impact from the VM's side at vSphere due to the VASA certificate registration needed. A downtime window should be planned in this scenario.


To remove, and add vCenter in Unisphere, apply the following steps: 

1) Log into Unisphere. 
2) Go to: ACCESS > VMware > vCenters. 
3) Select the vCenter that is registered in the Unity (only select the vCenter associated with the issue).
4) Click on the [Trash] icon to remove/delete vCenter.
5) After vCenter has been successfully removed, you must add it again by clicking on the [+] icon and completing the vCenter registration process again.


All I/O operations keep active and normal during this procedure. The ESXi hosts are automatically moved to the host's category at: [ACCESS > Hosts > Hosts]. 
After adding and successfully registering vCenter again, all ESXi hosts are automatically moved again from the hosts tab to the ESXi hosts category at: [ACCESS > VMware > ESXi Hosts].


Attention: Although there are no impacts during this procedure it is recommended to perform the troubleshooting steps during a programmed maintenance window. Or in a low production/utilization period.
If the issues persist after running this procedure, contact support for help.

Article Properties


Affected Product

Dell EMC Unity, Dell EMC Unity Family

Product

Storage

Last Published Date

28 Nov 2023

Version

3

Article Type

Solution