Connectrix B-Series: TruFOS License install failed - Failed to copy the file from the remote location using SANnav UI.

Summary: Attempting to import a license or TruFOS XML certificate is failing over command line and UI (SANnav).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Entering a command to import a license or TruFOS XML file in the following format is failing with the error message "License install failed - Failed to copy the file from the remote location":

license --install -h <IPaddress> -t <protocol> -u <user> -p <password> -f <filepath>

However performing a configuration backup to the same file transfer server with the same user account (using the configupload command) is working.

 

Cause

This can occur if there is a special character like an exclamation mark or bracket in the password for the user on the file transfer server.

 

Resolution

Fix:
Install the TruFOS license interactively using the CLI. 
See Dell Knowledge Base article:
Connectrix Brocade B-Series: How to apply a Brocade TruFOS Certificate to a switch

(The -p <password> segment from the license installation command is the only interactive argument of the command using CLI. When entering the license installation command without the -p <password> segment, you are prompted to manually enter the password. Here you can enter the same password (with the special characters), but it is accepted.)

 

Affected Products

Connectrix B-Series
Article Properties
Article Number: 000218010
Article Type: Solution
Last Modified: 30 Aug 2024
Version:  4
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