NAS backup fails with error, task failed because network connection issues prevented Workflow Manager Service from sending request to other service

Summary: Randomly PPDM NAS backups fails with the error: This task failed because network connection issues prevented Workflow Manager Service from sending a request to other service. NAS backup can also fail with error codes  AERR0018, ABNA0039 and error message: NAS agent error code 'ABNA0039'. Slice list read from metadata is empty for transactionId #### ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Symptoms: Error message in nasdm.log shows...
nasdm.log INFO [] [https-jsse-nio-9005-exec-13] [00000000-0000-4000-a000-000000000000][][TASK_ID:983b7981a333a5c7][TRACE_ID:xxx123][] [c.e.d.e.n.s.b.DeleteSnapshotService.updateSliceDetails(964)] - DeleteSnapshotService::updateSliceDetails: Before fetch the slice from SQLLite

Cause

From  nasdm logs it shows that fetching slice details from elastic search takes nearly 5 minute.

During that time another delete task is created which causing the failure of job.
NASDM could not respond to the WFM manager for backup action rest call within 1.5 Minutes

Resolution

Resolution: To resolve the issue with PPDM NAS backups failing, follow these steps:

  • Provide the NASDM.DB file to Engineering for manual cleanup.
Caution: Dell recommends that customers contact Dell Support for assistance with manual cleanup of the NASDM.DB file. This process requires technical expertise and may have unintended consequences if not performed correctly.

 

Additional Information

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000291038
Article Type: Solution
Last Modified: 20 Mar 2025
Version:  1
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