Avamar: Workaround for Oracle Restore Error "No backups with a label matching ''"
Summary: Restore operations using autobackup can be extremely slow and fail because Avamar processes over 255 minute‑long queries, leading to the “No backups with a label matching ''” error.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The restore operation is slow and may eventually fail with errors such as:
avtar Error <5183>: No backups with a label matching '' or backuptag 'c-555-444-ff' or labelnum 0 were found.
avtar Error <5920>: File 12/remsdev/CONTROLFILE.remsdev.c-555-444-ff not found.
Cause
Restoring with autobackup causes Oracle to issue many queries to Avamar. When the number of queries exceeds 255 and each takes about one minute, the restore becomes very slow.
restore spfile to '/oracle/admin/remsdev/avamar/spfileremsdev.ora' from autobackup;
Resolution
Restore the spfile or controlfile by specifying its actual name instead of using autobackup:
run {
allocate channel c1 type sbt PARMS="SBT_LIBRARY=/usr/local/avamar/lib/libobk_avamar64.so" format '%d_%U';
send channel c1 '"--prefix=12/remsdev/CONTROLFILE.remsdev." "--flagfile=/oracle/admin/remsdev/avamar/my-avtar-flags.txt" "--bindir=/usr/local/avamar/bin"';
restore spfile to '/oracle/admin/remsdev/avamar/spfileremsdev.ora' from CONTROLFILE.remsdev.c-12345-6789-01 ;
release channel c1;
Affected Products
Avamar, Avamar Plug-in for Oracle, Avamar ServerArticle Properties
Article Number: 000041592
Article Type: Solution
Last Modified: 24 سبتمبر 2026
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.