NetWorker: NetWorker의 테이프 라이브러리 로드 문제 해결

Summary: 이 문서는 지원자와 관리자가 라이브러리 또는 응용 프로그램 수준에서 라이브러리 로드 문제를 해결하는 데 도움을 주기 위한 것입니다. 문제가 논리적인지 물리적인지, 로봇, 드라이브 또는 매체 테이프 카트리지의 문제인지 확인합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 라이브러리에서 테이프 카트리지를 로드할 때 간헐적이거나 일관된 오류가 발생함
  • 라이브러리 매체에서 백업 또는 복구를 수행할 수 없음  
  • 라이브러리가 감지 가능하고 작동이 확인되었으며 준비됨
  • 로드 또는 레이블 작업을 수행할 수 없음
  • 레이블 없음으로 표시된 테이프
  • 시스템 또는 애플리케이션 로그에서 가능한 ASC/ASCQ/SCSI SENSE 오류 또는 메시지
  • 특정 또는 임의 라이브러리 작업을 수행하는 동안 간헐적이거나 일관된 오류가 발생합니다.

Cause

라이브러리 구성이 이전에 작동하던 중 갑자기 문제가 발생한 경우 감지 및 구성을 방해할 수 있는 변경 사항을 고려하십시오.

  • 로봇, 스위치 또는 어댑터 펌웨어, 드라이버 또는 구성 변경
  • 드라이브, 테이프 카트리지 또는 기타 라이브러리 구성 요소의 추가, 교체 또는 제거
  • NetWorker 소프트웨어 버전, 운영 체제 패치 변경
  • 데이터 경로에 있는 구성 요소의 정전 또는 재부팅과 같은 모든 하드웨어 이벤트
  • NetWorker 구성과 라이브러리 간의 불일치(예: 테이프 카트리지가 NetWorker의 통제를 벗어났음)

라이브러리가 작동하지 않는 경우 NetWorker 하드웨어 호환성 가이드 에서 하드웨어가 지원되는지 확인합니다(Dell 지원 계정 로그인 필요). 라이브러리가 부분적으로 기능할 수 있음을 기억하십시오. 검색만으로는 유용성이나 지원이 보장되지 않습니다.

Resolution

라이브러리 로드 문제를 해결하려면 마지막으로 알려진 변경 사항을 고려한 후 프로세스를 기본 구성 요소로 이관하고 개별적으로 테스트하여 문제를 해결하십시오.

필요한 데이터가 수집됨 NSRGet 로 실행할 때 -o:d 스위치와 함께 전달하면 안 됩니다. NetWorker: NSRGet NetWorker 데이터 수집 툴을 사용하는 방법

그렇지 않은 항목은 수동으로 시도할 경우 위험하다고 간주될 수 있는 작업으로 제한됩니다.
 

경고: 이러한 명령 중 일부는 SCSI 재설정을 유발하여 테이프 디바이스를 되감을 수 있습니다. 호스트에서 액세스할 수 있는 활성 테이프가 있는 경우에는 사용하지 마십시오.

라이브러리 로드: 커뮤니케이션


라이브러리 로드: 물리적 작업

  • 라이브러리 작업이 기본 수준에서 물리적으로 가능한지 확인합니다. 라이브러리가 활성화되지 않을 때 테스트가 수행되고 테이프 카트리지가 원래 위치로 교체되었는지 확인합니다.
먼저 테이프 카트리지 변위를 확인합니다.
sjirdtag <changer address>

그런 다음 테이프 카트리지를 요소 간에 이동하고 다시 원점으로 이동합니다.

sjimm <changer address> <drive|slot|inlt|mt> <element_number> <drive|slot|inlt|mt> <element_number>
  • 오류가 예상될 수 있는 몇 가지 상황이 있습니다. 예를 들어, 라이브러리 수준에서 자동 꺼내기를 사용할 수 없는 라이브러리는 드라이브에서 다른 요소로 이동하려고 할 때 오류가 발생합니다(테이프 카트리지는 mt -f <device_handle> offline 요소 밖으로 이동하기 전에 명령).
  • 로봇 작업, SCSI ASC/ASCQ 코드 오류를 시도할 때 오류가 산발적으로 또는 일관되게 반환되는 경우 검토를 위해 라이브러리 공급업체에 에스컬레이션하는 것이 좋습니다.

라이브러리 로드: 논리 연산

일단 물리적 작업에 오류가 없다는 것이 확인되면(적어도 피상적으로는) NetWorker 내에서 문제를 추적할 수 있습니다.

  • NSR 주크박스 상태 정보를 로봇의 테이프 카트리지 정보와 비교하여 라이브러리의 레이아웃을 결정하고 준비 상태를 확인합니다.
nsrjb [<-j library_name>] -C
sjirdtag <changer address>
  • 영향을 받는 드라이브에 테이프를 매우 자세하게 로드하려고 시도합니다.
nsrjb [<-j library_name>] -lvvvvv -f <device_handle> -S <slot_number>

라이브러리가 문제 없이 반복적으로 로드되는 경우 로드 문제는 지속적인 장애가 아닌 특정 상황 요인에 의해 발생할 수 있습니다. 로드 실패로 이어지는 조건을 격리하기 위해 모든 노력을 기울여야 하며 조건을 디버깅해야 합니다(아래 참조).

  • 일반 로드 작업이 실패하는 경우, 특히 볼륨이 'unlabeled'로 표시된 경우 로드 시도 중에 레이블 읽기가 실패한 것입니다( 마운트 실패). 마운트하지 않고 동일한 테이프를 동일한 드라이브에 매우 자세하게 다시 로드해 봅니다.
nsrjb [<-j library_name>] -lnvvvvv -f <device_handle> -S <slot_number>
  • 독립 실행형 레이블 검증을 수행하여 레이블 읽기 오류가 일시적인지 또는 일관성이 있는지 테스트합니다.
nsrmm -pvvvvv -f <device_handle>
  • 레이블을 성공적으로 읽은 경우 테이프 디바이스를 물리적으로 로드한 후 준비되기 전에 레이블 읽기 시도가 발생하는 것으로 문제가 해결될 수 있습니다. 이 경우 시스템 환경 또는 시작 스크립트에서 변수 설정을 시도할 수 있습니다.
MAX_LOAD_RETRIES=10

변수를 설정한 후 복합 로드/마운트(레이블 읽기) 작업 중에 로드 작업이 여전히 실패하는 것 같으면 디버깅 섹션으로 이동합니다.

    라이브러리 로드: 디버깅

    다른 모든 방법이 실패하면 SME(Subject Matter Expert)에게 문의하기 전에 문제 디버깅에 도움이 되는 적절한 데이터를 수집합니다.

    • NetWorker에서 문제를 재현하기 전에 NSR 주크박스 리소스에서 디버그 추적 수준을 5로 변경합니다
    • 또한 다음을 사용하십시오. dbgcommand 실행 중인 디버그 레벨을 높이려면 nsrdnsrmmgd 5에 대한 프로세스
    • 고려 truss/tusc/strace, pstack, gcore/gencore 적절한 nsrlcpd 문제 이벤트 이전 및 도중
    • 시스템 환경(Windows) 또는 시작 스크립트(UNIX)에서 디버그 변수를 설정하여 더 풍부한 디버깅 데이터를 가져옵니다.
    SJI_DEBUG=9
    LUS_DEBUG=9
    CDI_DEBUG=9
    SCSI_DEBUG=9
    JBDEBUG=9

     

    경고: 시작 후 문제가 신속하게 재현되지 않는 한 디버그 로깅이 과도할 수 있습니다. 환경 변수를 재생에서 제거하기 위해 서비스가 종료됩니다.

    위의 제안 사항 중 어느 것도 도움이 되지 않으면 디버그에서 수집된 증거가 내부 이상을 시사하는 경우 NetWorker의 테이프 라이브러리 감지 문제 해결NetWorker의 테이프 라이브러리 액세스 문제 해결에 따라 라이브러리 공급업체의 지원을 받으십시오; 그렇지 않으면코드 결함 가능성을 조사하기 위해 NetWorker 지원 내에서 디버그 출력을 에스컬레이션해야 합니다.

    Additional Information

    kA2j0000000R37vCAC_4_0
    이 문서는 NetWorker를 사용한 테이프 라이브러리 문제 해결 시리즈 중 하나입니다.

    Affected Products

    NetWorker

    Products

    NetWorker Series
    Article Properties
    Article Number: 000079463
    Article Type: Solution
    Last Modified: 30 مارس 2026
    Version:  4
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.