Openshift 事件代码:1038CLST0005
Summary: Pod 容器等待时间超过 1 小时
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
某个容器上特定命名空间中的某个 Pod 处于等待状态的时间超过 1 小时。
Cause
如果 Pod 卡在 Waiting 状态,则它已被调度到工作节点,但无法在该机器上运行。同样,来自 kubectl 的信息描述了......应该提供信息。等待 Pod 的最常见原因是拉取映像失败。
Resolution
诊断:
- 通过 oc -n 检查 pod 事件$NAMESPACE描述 pod $POD。
- 通过 oc -n 检查 pod 日志$NAMESPACE$POD -c $CONTAINER 日志
- 检查是否缺少文件,例如 configmaps/secrets/volumes
- 检查 Pod 请求,尤其是 GPU 等特殊请求。
- 检查节点污点和功能。
缓解措施:
请参阅容器等待
支持:
如果上述所有步骤都无法解决问题,请联系 Dell EMC 技术支持以进行进一步调查。
Affected Products
APEX Cloud Platform for Red Hat OpenShiftArticle Properties
Article Number: 000217414
Article Type: Solution
Last Modified: 18 سبتمبر 2026
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.