XtremIO: Not all logs were processed due to timeout limitation

Summary: During the running of Health Check Script on XtremIO messages stating that not all logs were processed due to timeout limitation appear.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During the running of Health Check Script on XtremIO messages stating that not all logs were processed due to timeout limitation appear as below.

13:16:07 - System Health Check Results:
13:16:07 - ----------------------------
13:19:04 - X1-SC2: Not all logs were processed due to timeout limitation (6 files processed out of 21)
13:21:16 - X1-SC1: Not all logs were processed due to timeout limitation (6 files processed out of 21)
13:23:33 - X2-SC1: Not all logs were processed due to timeout limitation (6 files processed out of 21)
13:25:34 - X2-SC2: Not all logs were processed due to timeout limitation (5 files processed out of 21)

Cause

These messages can safely be ignored.
When the Health Check Script runs, it looks back through the logs to check for any issues, but most of the time there are too many for it to look through,
This is not a problem because it always checks the most recent first.
There is a time limit set so that it does not stall the health check by looking through all the logs and risk having the whole health check script timeout.
These messages are informational to advise you that it only had the time to look through so many before it hit the time limit.
 

Resolution

Ignore these advisory messages.

Affected Products

XtremIO
Article Properties
Article Number: 000030662
Article Type: Solution
Last Modified: 01 جمادى الأولى 1447
Version:  8
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