Avamar: Der Workflow zum Herunterfahren des MCS reagiert beim Leeren von ClientRegistryService nicht mehr

Summary: Während des Herunterfahrens von Avamar reagierte der Prozess beim Beenden des MCS nicht mehr.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Der MCS-Start ist aufgrund des folgenden Fehlers fehlgeschlagen:

Startup Failed: Closing all connections to database. Server already started on port: 7778 

Cause

Die Spalte ClientRegistryService Die Leerung reagiert nicht mehr, wenn MCS heruntergefahren wird. Alle Services werden während des Herunterfahrens des MCS geleert, beginnend mit ClientRegistryService.

> 08/13-12:13:51.00900 [RMI TCP Connection(109)-10.241.180.21#904] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-12:13:51.00902 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService
> --
> 08/13-12:13:51.00993 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.cr.ClientRegistryService in 91 ms
> ...
> ...
> FINE: About to flush com.avamar.mc.pdm.ProxyDeploymentManagerService
> 08/13-12:13:52.00031 [FlushCacheThread#1092] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.pdm.ProxyDeploymentManagerService in 0 ms

Dieses Protokoll zeigt nur ClientRegistryService wird gespült, ohne zu vervollständigen.
 

> 08/13-00:06:29.00971 [RMI TCP Connection(3663)-10.241.180.21#68659] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService 

Die Hauptaufgabe des Spülens ClientRegistryService besteht darin, alle Clients aus dem Cache zu aktualisieren auf mcdb.

> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Start saving clients in ClientStore...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Flushing client f6a0975c4854536da1089c6800dc1212b2257a9a due to server shutdown,

Resolution

Ermitteln Sie die PID von "java.*mcserver"

 ps -eaf | grep "java.*mcserver"

Beenden Sie den MCS-Prozess manuell. 

pkill -9 <PID of "java.*mcserver">


Wenn dies während des Startvorgangs aufgetreten ist, starten Sie mit folgendem Befehl neu:

dpnctl start


Es ist möglich, aber nicht wahrscheinlich, dass die MCS-Leerung den MCS in einem inkonsistenten Zustand belässt. So stellen Sie die vorherige Leerung wieder her:

dpnctl start --force_mcs_restore


Um sicherzustellen, dass alles in Ordnung ist und die Services erfolgreich gestartet wurden, können Sie den Status mit überprüfen.

dpnctl status
Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key)
dpnctl: INFO: gsan status: up
dpnctl: INFO: MCS status: up.
dpnctl: INFO: emt status: up.
dpnctl: INFO: Backup scheduler status: up.
dpnctl: INFO: Maintenance windows scheduler status: enabled.
dpnctl: INFO: Unattended startup status: enabled.
dpnctl: INFO: avinstaller status: up.
dpnctl: INFO: ConnectEMC status: up.
dpnctl: INFO: ddrmaint-service status: up.

Affected Products

Avamar

Products

Avamar, Avamar Server, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000079437
Article Type: Solution
Last Modified: 07 جمادى الآخرة 1447
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.