Avamar: ClientRegistryService를 플러시하는 동안 MCS 종료 워크플로가 응답을 중지함

Summary: Avamar를 종료하는 동안 MCS를 중지하는 동안 프로세스 응답이 중지되었습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 다음 오류로 인해 MCS 시작에 실패했습니다.

Startup Failed: Closing all connections to database. Server already started on port: 7778 

Cause

ClientRegistryService MCS가 종료될 때 플러시가 응답하지 않습니다. MCS 종료 시 플러시됩니다. 다음 메시지부터 모든 서비스가 플러시됩니다. ClientRegistryService.

> 08/13-12:13:51.00900 [RMI TCP Connection(109)-10.241.180.21#904] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-12:13:51.00902 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService
> --
> 08/13-12:13:51.00993 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.cr.ClientRegistryService in 91 ms
> ...
> ...
> FINE: About to flush com.avamar.mc.pdm.ProxyDeploymentManagerService
> 08/13-12:13:52.00031 [FlushCacheThread#1092] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.pdm.ProxyDeploymentManagerService in 0 ms

이 로그에는 ClientRegistryService 완료하지 않고 플러시되고 있습니다.
 

> 08/13-00:06:29.00971 [RMI TCP Connection(3663)-10.241.180.21#68659] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService 

플러싱의 주요 작업 ClientRegistryService 캐시에서 모든 클라이언트를 다음으로 업데이트하는 것입니다. mcdb.

> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Start saving clients in ClientStore...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Flushing client f6a0975c4854536da1089c6800dc1212b2257a9a due to server shutdown,

Resolution

의 PID 구하기 "java.*mcserver"

 ps -eaf | grep "java.*mcserver"

MCS 프로세스를 수동으로 중지합니다. 

pkill -9 <PID of "java.*mcserver">


시작하는 동안 이 문제가 발생한 경우 다음을 사용하여 다시 시작합니다.

dpnctl start


MCS 플러싱으로 인해 MCS가 일관되지 않은 상태로 남을 가능성은 있지만 그럴 가능성은 없습니다. 이전 플러시를 복원하려면 다음을 수행합니다.

dpnctl start --force_mcs_restore


모든 것이 정상이고 서비스가 성공적으로 실행되었는지 확인하기 위해 상태를 확인할 수 있습니다.

dpnctl status
Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key)
dpnctl: INFO: gsan status: up
dpnctl: INFO: MCS status: up.
dpnctl: INFO: emt status: up.
dpnctl: INFO: Backup scheduler status: up.
dpnctl: INFO: Maintenance windows scheduler status: enabled.
dpnctl: INFO: Unattended startup status: enabled.
dpnctl: INFO: avinstaller status: up.
dpnctl: INFO: ConnectEMC status: up.
dpnctl: INFO: ddrmaint-service status: up.

Affected Products

Avamar

Products

Avamar, Avamar Server, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000079437
Article Type: Solution
Last Modified: 07 جمادى الآخرة 1447
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.