Avamar: Przepływ pracy zamykania MCS przestaje reagować podczas opróżniania ClientRegistryService

Summary: Podczas zamykania Avamar proces przestał odpowiadać, jednocześnie zatrzymując MCS.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Uruchomienie MCS nie powiodło się z powodu następującego błędu:

Startup Failed: Closing all connections to database. Server already started on port: 7778 

Cause

Polecenie ClientRegistryService opróżnianie przestało reagować, gdy MCS jest wyłączany. Wszystkie usługi są opróżniane podczas zamykania MCS, począwszy od ClientRegistryService.

> 08/13-12:13:51.00900 [RMI TCP Connection(109)-10.241.180.21#904] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-12:13:51.00902 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService
> --
> 08/13-12:13:51.00993 [FlushCacheThread#1042] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.cr.ClientRegistryService in 91 ms
> ...
> ...
> FINE: About to flush com.avamar.mc.pdm.ProxyDeploymentManagerService
> 08/13-12:13:52.00031 [FlushCacheThread#1092] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: Done flushing com.avamar.mc.pdm.ProxyDeploymentManagerService in 0 ms

Ten dziennik pokazuje tylko ClientRegistryService jest spłukiwanie bez zakończenia.
 

> 08/13-00:06:29.00971 [RMI TCP Connection(3663)-10.241.180.21#68659] com.avamar.asn.Node._stop
> FINE: Stopping the service container...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.asn.service.ServiceContainerImpl$FlusherThread.run
> FINE: About to flush com.avamar.mc.cr.ClientRegistryService 

Główne zadanie płukania ClientRegistryService jest zaktualizowanie wszystkich klientów z pamięci podręcznej do mcdb.

> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Start saving clients in ClientStore...
> 08/13-00:06:29.00972 [FlushCacheThread#68734] com.avamar.mc.cr.ClientStore.saveAll
> FINE: Flushing client f6a0975c4854536da1089c6800dc1212b2257a9a due to server shutdown,

Resolution

Znajdowanie identyfikatora PID "java.*mcserver"

 ps -eaf | grep "java.*mcserver"

Ręcznie zatrzymaj proces MCS. 

pkill -9 <PID of "java.*mcserver">


Jeśli do takiej sytuacji doszło podczas uruchamiania, uruchom komputer za pomocą polecenia:

dpnctl start


Jest możliwe, ale mało prawdopodobne, że płukanie MCS pozostawi MCS w niespójnym stanie. Aby przywrócić poprzedni rzut:

dpnctl start --force_mcs_restore


Aby upewnić się, że wszystko jest w porządku, a usługi zostały pomyślnie uruchomione, możesz sprawdzić stan za pomocą.

dpnctl status
Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key)
dpnctl: INFO: gsan status: up
dpnctl: INFO: MCS status: up.
dpnctl: INFO: emt status: up.
dpnctl: INFO: Backup scheduler status: up.
dpnctl: INFO: Maintenance windows scheduler status: enabled.
dpnctl: INFO: Unattended startup status: enabled.
dpnctl: INFO: avinstaller status: up.
dpnctl: INFO: ConnectEMC status: up.
dpnctl: INFO: ddrmaint-service status: up.

Affected Products

Avamar

Products

Avamar, Avamar Server, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000079437
Article Type: Solution
Last Modified: 07 جمادى الآخرة 1447
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.