NMDA DB2 19.4.0.0 yedeklemeleri her gece rastgele başarısız oluyor ve Hata 3 veriyor
Summary: NMDA 19.4.0.0 DB2 birkaç DB2 yedeklemesi dün gece Hata 3 ile başarısız oldu. Yeni aygıt oluşturulduktan ve yedekler iki depolama düğümüne dağıtıldıktan ve DB2 yeniden deneme ve zaman aşımı parametreleri ayarlandıktan sonra sorun çözüldü. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker Client 19.4.0.0: AIX 7.2
NMDA 19.4.0.0, DB2 Server v11.1.4.4
DB2 yedeklemeleri her gece
rastgele başarısız oluyor NMDA DB2 yedeklemesi Hata 3
hatasıyla başarısız oluyor DB2 yedeklemesi "nsrmmd" için lgto_auth failed: busy"
hatasıyla başarısız oluyorAğ veya güvenlik duvarı sorunu görülmüyor
Depolama düğümündeki daemon.raw bölümünde aşağıdaki iletilerden 1000'lerce var:
"5004-nfs lookup failed (nfs: No such file or directory):"
invalid save stream"
,"Cannot stat active file"
,"Cannot to collect deduplication statistics"
:"was aborted and removed from volume"
Error in nmda-messages.log libnsrdb2.log with debug=9:
153929 2/9/2021 10:34:50 PM 4 7 987 1 18153790 0 (client) (pid18153790) NSR severe Yedekleme oturumu başlatılamadı: meşgul. <--- bu EST zamanı, laboratuvarımda
işlendi 93412 09.02.2021 22:34:50 3 5 0 1 18153790 0 (istemci) (pid18153790) NSR hatası Eylem gerçekleştirilemedi 2. Durum 3 olarak değiştirildi.
153929 1612842069 4 7 987 1 19136950 0 (istemci) (PID19136950) NSR severe 39 The backup session could not start: %s'dir. 1 49 8 0 4 meşgul <--- GMT saati
93412 1612842069 3 5 0 1 19136950 0 (istemci) (pid19136950) NSR hatası 62 %d eylemi gerçekleştirilemedi. Durum %d olarak değiştirildi. 2 1 1 2 1 1 3
(pid = 18809144) (02/09/21 21:40:00.338942) nsrdb2sv_log_program_args: /usr/bin/nsrdasv -LL -T db2 -s (NW server) -g (group) -a *policy action jobid=2297950 -a *policy name=(policy) -a *policy workflow name=(workflow) -a *policy action name=(action) -y Tue Feb 23 23:59:59 GMT-0600 2021 -w Tue Feb 23 23:59:59 GMT-0600 2021 -m (client) -a *policy action jobid restart=Yes -b (pool) -t 1612810625 -o ....
(pid = 18809144) (02/09/21 21:40:00.624767) (DB) veritabanını yedekleme.
(pid = 18809144) (02/09/21 21:40:00.624939) set_db2_version: Exiting set_db2_version(): Return code: 10050000
(pid = 18809144) (02/09/21 21:49:08.731480) DbBackup: Şu hatayla çıkılıyor:
Yedekleme isteği hatası nedeniyle DB2MDME veritabanı yedeklenemiyor, SQLCODE: -2025, SQL2025N Bir G/Ç hatası oluştu. Hata kodu: "3". Bu hatanın oluştuğu ortam: "SATICI".
'dir.
(pid = 18809144) (02/09/21 21:49:08.731631) libdb2sv_main: ERROR: DbBackup() başarısız oldu.
(pid = 18809144) (02/09/21 21:49:08.731685) Yedekleme isteği hatası nedeniyle DB2MDME veritabanı yedeklenemiyor, SQLCODE : -2025, SQL2025N Bir G/Ç hatası oluştu. Hata kodu: "3". Bu hatanın oluştuğu ortam: "SATICI".
Critical error is nsrmmd busy error below:
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.797073 lgto_auth for 'nsrd' succeeded
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855631 lgto_parms for 'nsrmmd' succeeded
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855705 got 'store index entries' value of 'Yes'02
/09/21 21:32:46 (pid 18153790): 02/09/21 21:32:46.855803 'IDC-DB2' havuzuna kaydediliyor.
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855822 Server Enabled for Immediate mode
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.882267 lgto_auth for 'nsrmmd' failed: busy
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.882349 Cannot get the user credentials for direct save nsrmmd authentication: busy.
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.882439 Hata TÜRÜ 0, ÖNEM DERECESİ 0, SAYI -13, errnum -13, errstr 'meşgul'.
NMDA 19.4.0.0, DB2 Server v11.1.4.4
DB2 yedeklemeleri her gece
rastgele başarısız oluyor NMDA DB2 yedeklemesi Hata 3
hatasıyla başarısız oluyor DB2 yedeklemesi "nsrmmd" için lgto_auth failed: busy"
hatasıyla başarısız oluyorAğ veya güvenlik duvarı sorunu görülmüyor
Depolama düğümündeki daemon.raw bölümünde aşağıdaki iletilerden 1000'lerce var:
"5004-nfs lookup failed (nfs: No such file or directory):"
invalid save stream"
,"Cannot stat active file"
,"Cannot to collect deduplication statistics"
:"was aborted and removed from volume"
Error in nmda-messages.log libnsrdb2.log with debug=9:
153929 2/9/2021 10:34:50 PM 4 7 987 1 18153790 0 (client) (pid18153790) NSR severe Yedekleme oturumu başlatılamadı: meşgul. <--- bu EST zamanı, laboratuvarımda
işlendi 93412 09.02.2021 22:34:50 3 5 0 1 18153790 0 (istemci) (pid18153790) NSR hatası Eylem gerçekleştirilemedi 2. Durum 3 olarak değiştirildi.
153929 1612842069 4 7 987 1 19136950 0 (istemci) (PID19136950) NSR severe 39 The backup session could not start: %s'dir. 1 49 8 0 4 meşgul <--- GMT saati
93412 1612842069 3 5 0 1 19136950 0 (istemci) (pid19136950) NSR hatası 62 %d eylemi gerçekleştirilemedi. Durum %d olarak değiştirildi. 2 1 1 2 1 1 3
(pid = 18809144) (02/09/21 21:40:00.338942) nsrdb2sv_log_program_args: /usr/bin/nsrdasv -LL -T db2 -s (NW server) -g (group) -a *policy action jobid=2297950 -a *policy name=(policy) -a *policy workflow name=(workflow) -a *policy action name=(action) -y Tue Feb 23 23:59:59 GMT-0600 2021 -w Tue Feb 23 23:59:59 GMT-0600 2021 -m (client) -a *policy action jobid restart=Yes -b (pool) -t 1612810625 -o ....
(pid = 18809144) (02/09/21 21:40:00.624767) (DB) veritabanını yedekleme.
(pid = 18809144) (02/09/21 21:40:00.624939) set_db2_version: Exiting set_db2_version(): Return code: 10050000
(pid = 18809144) (02/09/21 21:49:08.731480) DbBackup: Şu hatayla çıkılıyor:
Yedekleme isteği hatası nedeniyle DB2MDME veritabanı yedeklenemiyor, SQLCODE: -2025, SQL2025N Bir G/Ç hatası oluştu. Hata kodu: "3". Bu hatanın oluştuğu ortam: "SATICI".
'dir.
(pid = 18809144) (02/09/21 21:49:08.731631) libdb2sv_main: ERROR: DbBackup() başarısız oldu.
(pid = 18809144) (02/09/21 21:49:08.731685) Yedekleme isteği hatası nedeniyle DB2MDME veritabanı yedeklenemiyor, SQLCODE : -2025, SQL2025N Bir G/Ç hatası oluştu. Hata kodu: "3". Bu hatanın oluştuğu ortam: "SATICI".
Critical error is nsrmmd busy error below:
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.797073 lgto_auth for 'nsrd' succeeded
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855631 lgto_parms for 'nsrmmd' succeeded
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855705 got 'store index entries' value of 'Yes'02
/09/21 21:32:46 (pid 18153790): 02/09/21 21:32:46.855803 'IDC-DB2' havuzuna kaydediliyor.
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.855822 Server Enabled for Immediate mode
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.882267 lgto_auth for 'nsrmmd' failed: busy
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.882349 Cannot get the user credentials for direct save nsrmmd authentication: busy.
02/09/21 21:32:46 (PID 18153790): 02/09/21 21:32:46.882439 Hata TÜRÜ 0, ÖNEM DERECESİ 0, SAYI -13, errnum -13, errstr 'meşgul'.
Cause
Yapılandırma/kaynak kullanılabilirliği sorunları.
Resolution
Aşağıdaki değişiklikler yapıldıktan sonra sorun çözüldü. Tek bir temel neden yoktur, ancak yeni cihaz oluşturmak ve aşağıdaki parametreleri ayarlamak en çok yardımcı oldu:
1. SN03
2'ye 1 yeni cihaz eklendi. Yedeklemeleri SN01 ve SN03'e (hedef oturum vb.)
eşit olarak dağıtılır3. Yedekleme başlangıç saatleri
değiştirildi 4. NMDA DB2 Uygulama bilgilerine şu parametreler eklendi:
NSR_MAX_START_RETRIES=50
NSR_FXBUSY_RETRIES=10
NSR_MMDB_RETRY_TIME=10
5. Hareketsizlik zaman aşımı 300'e yükseltildi, Yeniden Denemeler=2, Yeniden deneme gecikmesi=10
1. SN03
2'ye 1 yeni cihaz eklendi. Yedeklemeleri SN01 ve SN03'e (hedef oturum vb.)
eşit olarak dağıtılır3. Yedekleme başlangıç saatleri
değiştirildi 4. NMDA DB2 Uygulama bilgilerine şu parametreler eklendi:
NSR_MAX_START_RETRIES=50
NSR_FXBUSY_RETRIES=10
NSR_MMDB_RETRY_TIME=10
5. Hareketsizlik zaman aşımı 300'e yükseltildi, Yeniden Denemeler=2, Yeniden deneme gecikmesi=10
Affected Products
NetWorker Module for Databases and ApplicationsArticle Properties
Article Number: 000183668
Article Type: Solution
Last Modified: 28 رجب 1447
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.