PowerScale SupportAssist provision gets stuck in INCOMING

Summary: An issue where you begin provisioning SupportAssist in PowerScale OneFS and you check "# isi supportassist provision view" and it appears to be stuck in INCOMING.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When enabling SupportAssist, be sure to review KB PowerScale: Unable to Provision Dell SupportAssist OneFS code 9.5x and later for more information.

# isi supportassist provision start --access-key=<key> --pin=<pin>

# isi supportassist provision view

Provision Status:

   Current State: INCOMING
       Sub-state: INCOMING
 Success or Fail: -
Percent Complete: -
           Error:  -

And it appears to stop responding in this status.

 

Cause

Check /var/log/isi_crispies_d.log for errors similar to:

2024-10-04T11:28:34.667359-04:00 <3.3> powerscale-1(id10) isi_crispies_d[2406]: MainThread(isi_crispies_d:387) ERROR: Exception(main):400 Client Error: Bad Request for url: https://localhost:9443/ese/security/certificate/webserver

2024-10-04T11:23:58.143464-04:00 <3.7> powerscale-1(id10) isi_crispies_d[2406]: MainThread(ese_request.py:132) DEBUG: Response[400 /ese/security/certificate/webserver] Body: {"status_Code": 400, "message": "Provided certificate has expired."}

 

Resolution

An issue where a cluster in a non-GMT time zone leads to a false expiry of a certificate. Waiting several hours (preferably overnight), when the time it is looking for is hit, it provisions automatically.

Should 24 hours pass and it is still stuck in INCOMING, initiate a new logset gather and open a Service Request with Dell Technologies support for review.

Affected OneFS versions: 9.7.1.0 and later, 9.5.1.1 and later
The issue is resolved in OneFS 9.8.x.x and above.

 

Article Properties
Article Number: 000232371
Article Type: Solution
Last Modified: 05 جمادى الأولى 1446
Version:  2
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