PowerStore Alerts: Drive Evict State

Summary: PowerStoreOS 4.3.0 and above introduce a new feature to allow automatic eviction or manual eviction of drives. Evicting a drive allows to proactively copy the data from the evicted drive to a newly added drive. There should be minimal impact to the customer during this process. The eviction process allows for a faster recovery from a drive that is about to fail as the system can endure another drive failure (unlike with standard drive rebuild where we cannot lose another drive). PowerStoreOS automatically attempts to evict drives that reach 95% wear level to allow for faster recovery. The eviction process can only be performed on a single drive at a time, and it can be cancelled before the new drive is added and eviction (data copy) is actually started. ...

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Symptoms

When Dell PowerStore encounters a problem, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant solutions for these error alerts. If your problem is not resolved despite the solution that is provided, check the technical support contact options.

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Cause

Cause is self-explanatory in the Alert Texts mentioned in Resolution section.

Resolution

For Drive eviction procedure, refer KB 222359.

 

Alert ID XMS_DRIVE_EVICT_STATE_SYSTEM_REQUEST_TO_EVICT
Alert Text The system has set the drive in bus %(bus_num) encl %(encl_num) slot %(enclosure_slot) to be evicted because of high wear. The eviction process could not start because of %(pause_reason).
Error Code (0x00306402)
Description At 95% drive wear level, PowerStoreOS automatically initiates the eviction process for the drive. Due to a known reason the eviction process did not start.
Alert ID XMS_DRIVE_EVICT_STATE_CUSTOMER_REQUEST_TO_EVICT
Alert Text The user has set the drive in bus %(bus_num) encl %(encl_num) slot %(enclosure_slot) to be evicted. The eviction process could not start because of %(pause_reason).
Error Code (0x00306403)
Description User chose to evict a drive. Due to a known reason the eviction process did not start.
Resolution

Cause
These alerts indicate the eviction process was triggered (either by user or by the system) but cannot start due to an issue. The issue is described in the PAUSE_REASON.

Solution
Review the associated reason below and fix the underlying issue. Once the issue is resolved, the drive eviction process should automatically start.

PAUSE_REASON Action
evict_pending_no_dst_device After setting a drive to evict, a new drive needs to be added for the eviction process to start, add a new drive (same size or larger) on an empty slot on the same enclosure so the eviction process can start.

The reason can also indicate that an existing drive (that is not the source drive) has failed and rebuild completed. Replace the faulty drive. eviction process will resume once drive is replaced.

evict_pending_new_device_in_wrong_slot A drive was added in the wrong slot, possible reasons:
  • There is room for an additional drive in the DPE but a new drive was added to a DAE.
  • If the drive to evict is located on a DAE, the new drive cannot be located on the DPE. it must also be located on a DAE.
evict_pending_no_src_device Wait 10 minutes, if the alert persists, Contact Dell Technical Support for assistance
evict_pause_dp_in_vault Contact Dell Technical Support for assistance
evict_pause_dp_in_nvram_resiliency Contact Dell Technical Support for assistance
evict_pause_dp_in_recovery_mode Contact Dell Technical Support for assistance
evict_pause_dp_in_ndu Non-Disruptive Upgrade (NDU) is in progress, Eviction will start automatically once Non-Disruptive Upgrade (NDU) completes
evict_pause_dp_in_dip Data In Place Upgrade (DIP) is in progress, Eviction will start automatically once Data in Place Upgrade (DIP) completes
evict_pause_dp_in_sos There is a drive failure on the appliance, drive rebuild. replace the faulty drive. eviction process will resume once drive is replaced.
evict_pause_dp_in_degraded There is a drive failure on the appliance (rebuild either did not start yet or rebuild in progress), replace the faulty drive. eviction process will resume once drive is replaced.

 


 


Alert ID XMS_DRIVE_EVICT_STATE_EVICTING_PAUSED
Alert Text Eviction for drive in bus %(bus_num) encl %(encl_num) slot %(enclosure_slot) is paused due to an unexpected issue preventing the eviction process from proceeding. Reason: %(pause_reason).
Error Code (0x00306405)
Description Drive is in the process of eviction. Due to a known reason the eviction process is paused.
Alert ID XMS_DRIVE_EVICT_STATE_EVICTING_ERROR
Alert Text The eviction of drive in bus %(bus_num) encl %(encl_num) slot %(enclosure_slot) has stopped, reason %(pause_reason).
Error Code (0x00306406)
Description Drive is in the process of eviction. Due to a known reason the eviction process has entered an error state.
Resolution

Cause
Once the eviction process starts, PowerStoreOS copies data from the evicted drive to the newly added drive. If an issue was found during the eviction process, the process will either be paused or move to an error state. The issue is described in the PAUSE_REASON

Solution
Review the associated reason below and fix the underlying issue. Once the issue is resolved, the drive eviction process should automatically start.

PAUSE_REASON Action
evict_pending_no_dst_device The alert indicates a drive failed (a drive that is not the source drive) and the rebuild completed.  Replace the faulty drive. Eviction process will resume once drive is replaced.
evict_pause_dp_in_vault Contact Dell Technical Support for assistance
evict_pause_dp_in_nvram_resiliency Contact Dell Technical Support for assistance
evict_pause_dp_in_recovery_mode Contact Dell Technical Support for assistance
evict_pause_dp_in_sos There is a drive failure on the appliance causing Short of Spare (SOS), replace the faulty drive. eviction process will resume once drive is replaced.
evict_pause_dp_in_degraded There is a drive failure on the appliance (rebuild either did not start yet or rebuild in progress), replace the faulty drive. eviction process will resume once drive is replaced.

 


 

Alert ID XMS_DRIVE_EVICT_STATE_EVICTING_ABORTED
Alert Text The eviction of drive in bus %(bus_num) encl %(encl_num) slot %(enclosure_slot) has been aborted.
Error Code (0x00306407)
Description A drive is in the process of eviction, Dell support decided to abort the process due to an issue in the appliance.
Resolution Cause
This alert indicates the eviction process was aborted by Dell service personnel.

Solution
Contact Dell Technical Support for assistance

Additional Information

FAQ:

  • A drive has been successfully evicted, what happens next?
    Once eviction process completes, the evicted drive will be marked as FAILED (with reason: Evicted) and needs to be removed.
  • The drive under eviction failed during the eviction process, what happens next?
    If the drive under eviction fails during the eviction process, eviction will be PAUSED, and after 5 minutes the rebuild starts. as the rebuild starts, the eviction process completes successfully, since the copy-to mechanism is no longer relevant. the new drive is being rebuilt.

Affected Products

PowerStore
Article Properties
Article Number: 000382950
Article Type: Solution
Last Modified: 30 رجب 1447
Version:  3
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