PowerStore: Veeam compatibility with PowerStoreOS 4.3.0.x
Summary: After upgrading to PowerStoreOS 4.3.0.x, Veeam no longer works as expected.
Symptoms
After a PowerStoreOS upgrade to version 4.3.0.0, Veeam stops working as expected.
Example errors observed from the Veeam user interface:
- Error calling VolumeGet: {"messages":[{"severity":"Error","code":"0xE04040020002","message_l10n":"Unknown property volume.host requested.","arguments":["volume.host"]}]}
- Error calling HostGet: {"messages":[{"severity":"Error","code":"0xE04040020002","message_l10n":"Unknown property host.host requested.","arguments":["volume.host"]}]}
Cause
PowerStoreOS 4.3.0.0 is not supported, validated, or compatible with Veeam.
The Dell PowerStore Plug-In for Veeam Backup & Replication version makes no difference. Note that at the time of the release of PowerStoreOS 4.3.0.0, the official page for the plug-in showed the requirements as PowerStoreOS 3.0 - 4.2 (higher versions not supported).
Resolution
Before running a PowerStoreOS upgrade, carefully check support and compatibility with all aspects of the environment to ensure the new PowerStoreOS is fully compatible and validated to work with those tools, products, services, and so on.
A future version of PowerStoreOS will include full support for Veeam.