PowerProtect: Oracle RMAN Agent upgrade to 19.12 does not update the plug-in version in PowerProtect Data Manager internal database
Shrnutí: This article explains a workaround on how to properly update the Oracle RMAN Agent in PowerProtect Data Manager internal database.
Tento článek se vztahuje na
Tento článek se nevztahuje na
Tento článek není vázán na žádný konkrétní produkt.
V tomto článku nejsou uvedeny všechny verze produktu.
Příznaky
PowerProtect Data Manager internal database does show that the RMAN Agent version is NOT 19.12.
1- The way to check is by running from PowerProtect Data Manager CLI.
curl -k localhost:14300/index_host/_search?size=10000\&pretty | less
2- Look for the Oracle hostname and Check the Oracle RMAN Agent
1- The way to check is by running from PowerProtect Data Manager CLI.
curl -k localhost:14300/index_host/_search?size=10000\&pretty | less
2- Look for the Oracle hostname and Check the Oracle RMAN Agent
....
"name" : "<Oracle_hostname>",
"applicationsOfInterest" : [
{
"name" : "Oracle RMAN Agent",
"type" : "ORACLE",
"version" : "19.11.0.0", <--- 19.11 version instead of 19.12
Příčina
The agent software on the Oracle box has a problem that is corrected in version 19.13.
Řešení
Workaround:
Permanent fix:
- SSH as root to the Oracle box
- cd /opt/dpsapps/agentsvc
- ./unregister.sh
- mv agent-id.yml agent-id.yml.orig
- cd dbs/v1
- mv resources.db resources.db.orig
- cd ../..
- Check the PowerProtect Data Manager IP or FQDN in config.yml
- ./register.sh
Permanent fix:
- Upgrade PowerProtect Data Manager to 19.13
- Upgrade PowerProtect Data Manager Agent and Oracle RMAN agent to 19.13
Vlastnosti článku
Číslo článku: 000209744
Typ článku: Solution
Poslední úprava: 24 kvě 2023
Verze: 2
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.