NVP-vProxy. Не удается войти в систему с использованием учетных данных привилегированного пользователя, доступ привилегированного пользователя потерян
Shrnutí: Доступ к корневой учетной записи через устройство vProxy потерян.
Tento článek se vztahuje na
Tento článek se nevztahuje na
Tento článek není vázán na žádný konkrétní produkt.
V tomto článku nejsou uvedeny všechny verze produktu.
Příznaky
В веб-клиенте VMware vSphere не удается войти в устройство vProxy с использованием учетной записи root. Возвращаются ошибки «Доступ запрещен» или «Неверные учетные данные».
Вы не можете войти в систему с помощью учетной записи администратора vProxy из клиента SSH или vSphere. Возвращаются ошибки «Отказано в доступе» или «Неверные учетные данные».
ПРИМЕЧАНИЕ. Доступ с правами root по умолчанию заблокирован по протоколу SSH. Если в настройках файла конфигурации SSHD в vProxy не задано значение «root over SSH», корневой доступ возвращает «Отказано в доступе» по SSH. Доступ к учетной записи root можно получить с помощью подключения к консоли виртуальной машины веб-клиента vSphere.
Вы не можете войти в систему с помощью учетной записи администратора vProxy из клиента SSH или vSphere. Возвращаются ошибки «Отказано в доступе» или «Неверные учетные данные».
Příčina
Учетная запись привилегированного пользователя и администратор заблокированы, или учетные данные пользователя потеряны или неизвестны.
Řešení
Если доступ потерян для учетной записи пользователя root и администратора, необходимо повторно выполнить развертывание vProxy.
Если учетная запись root доступна:
Если учетная запись root доступна через подключение к консоли веб-клиента vSphere, подключитесь к vProxy через SSH и войдите с учетными данными администратора. Перейдите к учетной записи пользователя root с помощью следующей команды и укажите пароль привилегированного пользователя.
Рис. 1. Снимок экрана страницы пароля vProxy
Если учетная запись администратора заблокирована, войдите с корневой учетной записью из веб-клиента vSphere и сбросьте учетную запись администратора, используя pam_tally2 для сброса:
Если учетная запись root доступна:
Если учетная запись root доступна через подключение к консоли веб-клиента vSphere, подключитесь к vProxy через SSH и войдите с учетными данными администратора. Перейдите к учетной записи пользователя root с помощью следующей команды и укажите пароль привилегированного пользователя.
sudo su -Изменить (обновить) пароль привилегированного пользователя можно только в том случае, если у вас уже есть доступ к учетной записи root.
sudo passwd rootЕсли пароль пользователя admin потерян, но вы знаете пароль root, подключите его к vProxy из веб-клиента vSphere и войдите в систему как пользователь root. Пароль администратора можно изменить с помощью следующей команды:
passwd admin
ПРИМЕЧАНИЕ. При изменении пароля пользователя администратора необходимо обновить пароль vProxy в NetWorker. В противном случае он продолжает пытаться использовать старый пароль и блокирует учетную запись.
Рис. 1. Снимок экрана страницы пароля vProxy
Если учетная запись администратора заблокирована, войдите с корневой учетной записью из веб-клиента vSphere и сбросьте учетную запись администратора, используя pam_tally2 для сброса:
pam_tally2 --user admin --reset
Dotčené produkty
NetWorkerProdukty
NetWorker Family, NetWorker SeriesVlastnosti článku
Číslo článku: 000215827
Typ článku: Solution
Poslední úprava: 06 lis 2025
Verze: 7
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.