No Audio from Dell Soundbar Connected by USB to External Monitor

Summary: The following article provides information about a no audio issue on Dell soundbars. The article is a troubleshooting guide to identify and resolve a connection issue between the soundbar, monitor, and computer. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

External Monitors are not outputting sound through USB-connected soundbars

 

Dell soundbars and speakerphones have no sound after connecting your device to the USB hub on an external monitor.

No audio is heard when the cables are disconnected or in the wrong port. The soundbar connects to the downstream USB port on the monitor, which connects to the device or dock using the upstream USB port. (USB Type-C or Type-A.)

This affects the following Dell Devices:

  • Dell Pro Desktop Speakerphone SP3022
  • Dell Slim Soundbar SB521A
  • Dell Slim Conferencing Soundbar SB522A
  • Dell Pro Wired Speakerphone SP325

The following Dell monitors are confirmed to see this issue:

Table.1: Supported monitors
P-series monitor U-series monitor
P2222H (WOST) U2421E
P22223HC U2422H
P2421 U2422HX
P2423 U2422HE
P2422H (WOST) U2722D
P2423D U2722DX
P2722H U2722DE
P2722HE U2723QE and U2723QX
P2723D U3023E
P2723DE U3223QE
P2723QE  
P3223DE  
P3223QE  
P3421WM  

Cause

There is no data from the computer to the monitors downstream USB port, when the monitors upstream port is not connected to the computer. (USB Type-C or USB Type-B)

There is no connection between the computer and the monitors' downstream USB port to output audio over. (The soundbar or speakerphone is plugged into the monitors downstream USB port.)

Resolution

These ports are all specified in the monitors manual which can be found on the: Dell Support site

  1. Reseat each connection between the soundbar to the monitor.
  2. Reseat each connection between the monitor to the computer or docking station.
  3. Ensure that the two USB cables are properly connected to the correct ports on the monitor.
Note: The downstream cable is supplied with the soundbar or speakerphone device. The upstream cable is supplied with the monitor. (USB Type-C to Type-C or Type-A to Type-B.)


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Affected Products

Dell P2222H, Dell P2421, Dell P2422H, Dell P2422HE, Dell P2722H, Dell Slim Soundbar - SB521A, Dell Slim Conferencing Soundbar - SB522A, Dell Pro Wired Speakerphone SP325, Dell Pro Desktop Speakerphone SP3022, Dell U2421E, Dell U2422H, Dell U2422HE , Dell U2422HX, Dell U2722D, Dell U2722DE, Dell U2722DX, Dell P2223HC, Dell P2423D, Dell P2423DE, Dell P2723D, Dell P2723DE, Dell P2723QE, Dell P3223DE, Dell P3223QE, Dell U2723QE, Dell U2723QX, Dell U3023E, Dell U3223QE ...
Article Properties
Article Number: 000214957
Article Type: Solution
Last Modified: 29 Sept 2025
Version:  5
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