No Audio from Dell Soundbar Connected by USB to External Monitor
Summary: The following article provides information about a no audio issue on Dell soundbars. The article is a troubleshooting guide to identify and resolve a connection issue between the soundbar, monitor, and computer. ...
Symptoms
External Monitors are not outputting sound through USB-connected soundbars
Dell soundbars and speakerphones have no sound after connecting your device to the USB hub on an external monitor.
No audio is heard when the cables are disconnected or in the wrong port. The soundbar connects to the downstream USB port on the monitor, which connects to the device or dock using the upstream USB port. (USB Type-C or Type-A.)
This affects the following Dell Devices:
- Dell Pro Desktop Speakerphone SP3022
- Dell Slim Soundbar SB521A
- Dell Slim Conferencing Soundbar SB522A
- Dell Pro Wired Speakerphone SP325
The following Dell monitors are confirmed to see this issue:
| P-series monitor | U-series monitor |
|---|---|
| P2222H (WOST) | U2421E |
| P22223HC | U2422H |
| P2421 | U2422HX |
| P2423 | U2422HE |
| P2422H (WOST) | U2722D |
| P2423D | U2722DX |
| P2722H | U2722DE |
| P2722HE | U2723QE and U2723QX |
| P2723D | U3023E |
| P2723DE | U3223QE |
| P2723QE | |
| P3223DE | |
| P3223QE | |
| P3421WM |
Cause
There is no data from the computer to the monitors downstream USB port, when the monitors upstream port is not connected to the computer. (USB Type-C or USB Type-B)
There is no connection between the computer and the monitors' downstream USB port to output audio over. (The soundbar or speakerphone is plugged into the monitors downstream USB port.)
Resolution
These ports are all specified in the monitors manual which can be found on the: Dell Support site
- Reseat each connection between the soundbar to the monitor.
- Reseat each connection between the monitor to the computer or docking station.
- Ensure that the two USB cables are properly connected to the correct ports on the monitor.