PowerFlex 3.X: 게이트웨이 UI 404 오류

Summary: RCM 업그레이드 중에 PowerFlex Gateway UI에 로그인하면 404 오류가 표시됩니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 게이트웨이가 RCM 3.6.5를 사용하여 업그레이드되었습니다
  • PowerFlex Gateway UI에 로그인하면 다음이 표시됩니다.
    PowerFlex Gateway UI에 로그인할 때 404 오류 발생
  • 게이트웨이 scaleio.log에는 다음 출력이 표시됩니다.
    2024-02-08 09:13:09,094 [localhost-startStop-1] ERROR c.e.s.s.services.RequestMapUtils - vasa.provider.monitor.interval.seconds (60,60) must be a number between -2147
    483648, 2147483647.

 

영향

게이트웨이를 사용할 수 있게 될 때까지 업그레이드를 계속할 수 없습니다.

 

Cause

이 "/opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties" 파일에는 이미 줄에 있는 값과 쉼표가 부적절하게 추가된 많은 매개 변수가 있습니다.

예:

vasa.provider.ips=,
vasa.provider.monitor.port=,
vasa.provider.monitor.interval.seconds=60,60
#vasa.provider.replica.set.name=vasa-rs
..
lia.ldap.commands.batch.size=256,256
upload.commands.batch.size=16,16
lia.upload.commands.batch.size=256,256
validate.node.commands.batch.size=256,256

cloudiq.enabled=true,true

 

Resolution

이 문제는 "/opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties" 매개 변수를 설정해야 합니다. 확실하지 않은 경우 다른 게이트웨이를 사용하여 비교하십시오. 이 예는 완전하지 않습니다. 잘못된 매개 변수가 추가된 줄이 더 많습니다.

위의 예에서 줄은 다음과 같아야 합니다.

vasa.provider.ips=
vasa.provider.monitor.port=
vasa.provider.monitor.interval.seconds=60
#vasa.provider.replica.set.name=vasa-rs
..
lia.ldap.commands.batch.size=256
upload.commands.batch.size=16
lia.upload.commands.batch.size=256
validate.node.commands.batch.size=256

cloudiq.enabled=true

 

빈 줄에는 쉼표가 제거되고 실제 값이 있는 줄에는 쉼표와 추가 값이 제거되었습니다.

이 작업이 완료되면 게이트웨이 서비스를 다시 시작합니다.

# systemctl restart scaleio-gateway

 

영향을 받는 버전

PowerFlex RCM 3.6.5

수정된 버전

PowerFlex RCM 3.8.8

 

Affected Products

PowerFlex Appliance
Article Properties
Article Number: 000221984
Article Type: Solution
Last Modified: 30 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.