ECS: Veeam and ECS compatibility

Summary: This KB article describes Veeam and ECS compatibility.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Users run Veeam to archive data to ECS using Data Domain.
This KB is to address issues with direct implementation of Veeam with ECS using the S3 protocol.

Cause

Veeam is unable to browse the bucket.
After configuring the Veeam application with ECS S3 credentials, the user is unable to browse the buckets.
After configuring the Veeam app with ECS S3 credentials, the user is not able to browse the buckets. 
The Veeam application is stuck at this screen and does not retrieve the contents of the bucket. 

Resolution

Verify the user configuration. The following screenshots are from the user Veeam application:

1. Open the Backup Infrastructure view. In the inventory pane, right-click the Backup Repositories node and select Add Backup Repository. In the Add Backup Repository dialog, select Object Storage > S3 Compatible.
In the Add Backup Repository dialog, select Object Storage > S3 Compatible.  
2. Select S3 Compatible. 
Select S3 Compatible  
3. Enter the appropriate information:
Fill in the appropriate details 
4. Click Next:
Click Next 
Here you can see the buckets configured for that Object User.

Next, Veeam support should provide a registry key to add on the veeam-server (HKLM\SOFTWARE\Veeam\Veeam Backup and Replication\ S3RequestRetryTotalTimeoutSec).

Now the user can browse the bucket.

Additional Information

For more information, see Veeam Help Center.

 

Affected Products

ECS Appliance

Products

ECS Appliance, ECS Appliance Hardware Gen2 U-Series, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption
Article Properties
Article Number: 000045919
Article Type: Solution
Last Modified: 26 Aug 2025
Version:  4
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