El respaldo de NetWorker vProxy falla con el mensaje "RPC error: Failed to connect to host " y "Err: 5037-Cannot resolve IP address from Host "

Summary: La integración de protección de VMware de NetWorker (NVP) está configurada con el dispositivo con vProxy. La implementación de vProxy tuvo algunos problemas con la resolución de nombres y DNS. Los respaldos de máquinas virtuales (VM) para algunas máquinas virtuales fallan con un mensaje de error de resolución de nombres no válido. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

En el archivo /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR:  [1268:7F4794001E30] ddp_connect_with_config_internal() failed, Hostname: 110DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR:  [1268:7F4794001E30] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR:  [1268:7F4778001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR:  [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
---- Skipping Lines ----
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T13:59:20Z ERROR:  [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:06:29Z INFO:   [1268:7F476C001C80] ddcl_nfs_open_tcp - Timed out trying to resolve the hostname: DD###_T4
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR:  [1268:7F476C001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR:  [1268:7F476C001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0

Desde /nsr/logs/daemon.raw:
71193 MM/DD/YYYY HH:MM:SS AM  0 0 0 4988 4616 0 my_networker_server nsrd NSR info Media Info: Failed to start nsrsnmd on host my_storagenode_name, error `RPC error: Failed to connect to host 'my_storagenode_name': Remote system error - No connection could be made because the target machine actively refused it.
 
Consulte el artículo 22793 de Dell, NetWorker: Cómo utilizar nsr_render_log

Cause

Problema de resolución de nombres en el nivel de host de vProxy

Resolution

Agregue manualmente la dirección IP, el FQDN, el nombre corto de vCenter, Data Domain, NetWorker y el nodo de almacenamiento en /etc/hosts del host vProxy.

Inicie los respaldos de VM de vProxy ahora.
  1. Inicie sesión en la sesión de PuTTY de vProxy como administrador y, a continuación, cambie a root:
sudo su - root
  1. Ejecute el siguiente comando para crear una entrada /etc/host
# echo "IP_of_vCenter FQDN_of_vCenter ShortName_of_vCenter" >> /etc/hosts
MUESTRA:
# echo "10.10.10.10 myvcenter.abc.com myvcenter" >> /etc/hosts
# echo "IP_of_DD FQDN_of_DD ShortName_of_DD" >> /etc/hosts
# echo "IP_of_NWServer FQDN_of_NWServer ShortName_of_NWServer" >> /etc/hosts
# echo "IP_of_StorageNode FQDN_of_StorageNode ShortName_of_StorageNode" >> /etc/hosts

Products

NetWorker Family
Article Properties
Article Number: 000219162
Article Type: Solution
Last Modified: 23 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.